title
TOP / Wiki / Diary / Profile / PC / BBS / Mail
わたしの日記は日々の出来事の鬱憤晴らしの毒だし日記がメインです。 相当病んでいます。くだを巻いています。許容出来る方のみのアクセスをお願いします。 また、この日記へのリンクは原則自由にして頂いても結構ですが、 写真への直リンクを張るのはご遠慮下さい。内容に関しては、一切保証致しません。
カテゴリ一覧 Network, Internet, IPv6, DC, NTT, Comp, Linux, Debian, FreeBSD, Windows, Server, Security, IRC, 大学, Neta, spam, , 生活, 遊び, Drive, TV, 仕事,
過去日記:



2017年08月19日() [晴れ]

[] アシッドラシーヌ

acidracinesのケーキ。本当においしいの。
後でしったのは、食べログの評価で3.9という頭のおかしい異常ともいえる高評価。
ということで、お持ち帰り♪






この7層のケーキ。横にわって、単独で食べるとたいしたことないのに、縦に食べたときのハーモニーは素晴らしい。不思議。
不調和と思いそうなのに調和している。そんな感じ。これはね、もう、センスとしかいいようがない。

アシッドラシーヌ
大阪府大阪市中央区内平野町1-4-6
06-7165-3495
[月〜土] 11:00〜20:00, [日] 11:00〜18:00

[ コメントを読む(0) | コメントする ]

[Life][] 奈良県橿原市 ビストロイマイ

母親の誕生日で妹と一緒にお祝い。お手軽なフレンチコース。
前菜、サラダを含め、5品+デザートと珈琲です。
全開5月に訪問したときも貸し切り、今回も貸し切りでした。

テーブル


前菜、私は生ハム。



食前酒と白ワイン。



鶏のスフレ。



断面、パンにつけていただくととても幸せ。



ポテトのスープ。



ヒレステーキ、季節の野菜仕立て。今回はキノコ(マイタケ?)とオクラ、マッシュポテト。
今回は少し甘辛い感じでした。



断面、ミディアムレアぐらい?



サラダ



お誕生日ケーキ。ナッツが香ばしくておいしい!



デザートと珈琲。



お酒も付いて、コースで、結構お得。
おいしいモノを食べて、長生きして私をもっと養ってね♪

ビストロイマイ
奈良県橿原市四条町25-9
050-5593-4031
11:30〜14:30(L.O.13:30), 17:30〜22:00
定休日: 木曜日

[ コメントを読む(0) | コメントする ]

2017年08月18日(金) [晴れ]

[Server] 昨年、なんちゃって大容量ストレージを作ったよ

本当はDL380 G8で2.5インチ 2TBのディスクを16本とかやりたかったのだけど、コストの問題で、DL180 G6で妥協。
ちょうどよいモノが出回っていたので、3台調達して、ディスクだけ入れ替え。
もちろん、冗長化電源、DualCPUなのでちょうどよさそう。

3台あるのは、1台部品取り用(どうやら故障品を引いてしまった様子)、2台の内1台はコールドスタンバイ機、すなわち予備ですね。
中古品なので、部品取りをした上、最終的に抜け殻になったので、ハードオフに処分をしにもっていきました。

奴らはバカなので、本体のホットスワップ電源ユニットを抜いて、ドライブベイを外してもっていくと、1台のなのに、分割して計算し始めました。 値段が全く付かなかったので、電源ユニットだけ持ち帰り冗長化電源の予備として確保しておくことに。
現行販売品であっても、古いですねー、の一言、動作確認もしません。
まともに動作確認や調べようともしないので、動くモノなどまともなモノを持ち込むのが間違いです。ゴミ捨て場です。 ちゃんと査定+評価するのであれば、こちらもそれなりの対応をします。

脱線からもどして、当初、調達した構成は、1TB x 8 が2セット、残り1セットは300G SAS x 6 の構成。 大量にSATA 1TBのHDDとSAS 300GBのディスクがあまりましたが、1TBのディスクは、カセットの要領で、テンポラリディスクとして転用します。 いわゆるアーカイブ保存用ですね。
DL180G6には、不具合が有り、PCIeにSmartArrayオプションをつけると、温度管理に不具合が生じて、FAN全開で回るというバグ。 これは、ファームウェアでも改善されないようで、困りました。
同じ問題を、 serverfult HP ProLiant DL180 G6 Fan Noise?というところに投稿が。組み合わせで発生する様子。また、PCIeに他のSASカードをつけて、miniSASで接続した場合も同様にこの問題が発生するので、ドライブベイのFANユニットの温度状態が正しくとれないのが原因では無いかと推測しています。

また、PCIeにカード類をさす場合とささない場合では、PCIe周りのBIOSが異なるようで、起動中になにかしら、ファームウェアの入れ替え作業を実施してるえるようなメッセージが表示されおり、このタイミングでうっかり電源が落ちると、BIOSが飛んだりして大変なことになりそうです。ってかマニュアルにも記載が見つけれなかったがいろいろと癖がありそう。

原因がわかったので、3台ある内のDL180から内蔵用のP410/512 FBWC コントローラー(内部接続専用)用を移植したら、FAN全開問題が解消さました。そして、RAID6ボリュームを作成。~これだけあると、構成がばらばらなので、PCIe接続用SmartArray、FBWC、メモリなどあるので、調整ができてちょうどよいですね。

構成は、Xeon 5640 + MEM 24GB + P410 + WD RED 4TB x 8(RAID6)で24TBストレージになりました。
ディスクは購入時は、1.5万円ほどでしたけが、その後値段が上がったのでよいタイミングで調達したと思います。6TB,8TBはGiga単価が高いこと、故障率が高いで、みんな4TBにいったんだとおもいます。

ある程度動いたので、Twitterに、 投稿



リツイート件数が892件いただきました。女子のお家のNASですよ。
892というと、Cisco 892FJがほしい(w

OS はFreeBSDでzfs+dedup採用です。dedupを使う場合、CPUにDiskIOをかなり消費します。
元々、このストレージはデータバックアップなので、snapshotを走らせ、一日一回データバックアップが裏で動くのですが、この際、dedupがあると、7〜8倍ぐらい入ります。その上で、圧縮ボリュームにしてます(以前の実績値)。圧縮を有効にすると、実際の容量とはかけ離れてきてしまうので、実際使っている容量がわかりづらくなります。さて、既存のDL120からデータをお引っ越ししようと、zfs sendを行おうとすると、40TBを超え、1Gbpsでは1週間ほどかかる見込み。実際に見えていない容量もあるので、計算上はもっとかかる可能性があります。
実際に転送をしてみると、転送先ではあまり、dedupが効かない感じ。。。まだ、最初の方だし仕方ないですかね。



また、今までの経験から、1Gbpsでは帯域が厳しく、10Gbpsに行くにもちょっと...と悩んでいたので、Link Aggregation(LACP/802.3ad)を採用しました。その上で、データ転送をしたら、ちゃんと2Gbps近く出ることもわかりました。
AxalaxAのスイッチとFreeBSDと組み合わせると、AlaxalAから来るトラフィックは、同一mac/ip/port であっても、リンクが分散してくれるようなので、よい実装です。帯域を使い切れますね。

転送元はほぼ、1Gbpsきっちり出てくれています。
が、なかなか終わりませんので、放置しましょう。

結局終わりそうにも無いので、古い不要になったsnapshotを消して少し軽くしてから、再度転送しようかとおもいます。
ちなみに、FANが全開で回ると、40Wぐらい消費電力が増えますが、負荷がさほど高くないときは、100〜120W前後程度で落ち着いています。
HBAの問題が解消されないと、ものすごいFANの音と、1kwhあたり、30円で計算すると、28.8Kwh、すなわち、864円程度電気代が値上がりすることになりますので、非常にシビアな問題です。

[ コメントを読む(0) | コメントする ]

[IPv6][Internet] IPv6 Onlyに対応しているサイトは...?

2000年過ぎから、我が家はIPv6 Onlyでも動くようにサイトを構築している。
そんななか、IPv6が当たり前の環境にいたが、いま、現状でどういう感じかと探ってみた。

昨今、IPoE(VNE)や、IPv6を標準に提供する元電力系ISP(auひかりone)、そして、Softbank光やnuro光など増えてきていること、 モバイル3社は2017年度中にIPv6導入することを発表している。
また、Appleは2015年6月より、アプリが IPv6 Only Networkに対応していることを 必須としているので、そのあたりも確認していきたい。

環境は、Windows 7 + Chrome 、IPv6 Onlyでアクセスする。
尚、GoogleやFacebookは、IPv4が無くとも全く困らないことをお伝えしておく。

ターゲットにしたWebサイトは、下記の通り。主要OSについては、OS Updateができるかも確認している。
DNS Cache ServerはGoogle Public DNSを使用している。Cache ServerがDualStackに対応していることがおそらく世の常なので、権威サーバーがIPv6トランスポートをもっているかどうかは対象としていない。

長いので、最初に結果を書いておく。

主要OS

Microsoft
Topページすらまともに表示できない。 画像やCSSなど外部サーバーでIPv4のみ。 supportやtechnetも繋がらない。 Windows UpdateはIPv6 Onlyでも動作した。 Apple
Apple Storeはまともに表示できない。 itunesはだめ。もちろん、AppStoreもダメ。 アプリには対応を要求する割には....情けない。 apple.co.jp はwww.apple.comにリダイレクトするだけの簡単な仕事なのに未対応。 なんで、これぐらい出来ないのかな?

日本国内携帯3社

NTTdocomo
www.nttdocomo.co.jp にほぼ集約されているのでコンテンツは閲覧可能。 だが、dpointや、mydocomoなど、IPv6非対応のため、使えない。 サービス紹介、エリア検索等については、サイトそのものは、同一FQDN内におさまっているのでおおよそOK エリア地図もGoogleサービスを使用しているため、表示可能。 Softbank
mysoftbankは非対応、ybbのリンクまでは行けるが、契約がらみでは非対応。 サービス紹介については、サイトそのものは、同一FQDN内におさまっているのでおおよそOK 対応エリア検索の地図はYahooJapanの外部を利用しており、こちらが非対応。 KDDI
Topページは見れるが正しく表示できない。 外部ドメインにCSS/画像などをとりに行くものの、サーバーがIPv6に非対応。 でも、そのほかダメ。AUのサイトに関してはそもそも非対応。 以前はau(www.au.kddi.com)も対応していたが、ドメイン変更に伴いアクセス不可。

IPoE VNE/主要ISP
※ IPoEに関しては、NTT東西より 申し込み受領された事業者を対象としており、サービス開始の有無については考慮していません

NTT東西
フレッツサイトはIPv6に非対応 コーポーレートサイトはNTT東はAAAAが付与されているが、正しく応答しない、壊れた環境。 BBIX
何ら問題無いが検索窓がYahooに依存しておりNG JPNE
何ら問題無い Transix
何ら問題無い FreeBIT
何ら問題無いが、DTIは非対応 Biglobe
サイトは見れる。 ただし、入会サイトやアイドル、グラビアなどダメ。 メールのリンクなど表示されない。 そもそも認証系サイトがIPv4にしか対応していない。 AsahiNet
論外。AAAAすらついてない。 v6確認サイトのみ外部ドメインのサーバーで確認可能 OCN
完全アウト、まともに閲覧出来ない。KDDIと同レベルかそれ以上に論外。 その他メールなどもダメ。 OCN(Global IP Network)
さすがにこちらは大丈夫。 検索窓はNG IIJ/IIJMIO
問題無し Plala
全部対応、マイページ、WebメールなどもOK Nifty
非対応。AAAAすら無い So-net
www.so-net.ne.jpは対応しているが、 nuro.jpは非対応。www.so-net.ne.jp のSSLページは挙動が変でIPv6環境では正しく表示出来ない。

 主要OS:
 モバイル事業者 3社の対応状況:
 IPoE VNE/主要ISP:

もう、こちらは、ざくっと。結論から言うと、初期VNE3社および、IIJ/Plalaぐらいしかまともなサイトは無かった。 初期VNE事業者 3社は個人の手続きを対象としておらず、ローミングなど、ISP事業者にサービス紹介にとどまり、普通にDualStack化されている。しかし、ISPでいうと、IIJ/Plalaぐらいしかまともに動作していなかった。


 クラウド事業者/ホスティング事業者:

AWSについては、サービスとしてはIPv6に積極的に対応していると、 IPv6対応クラウドサービスワークショップ公言している。が、自Webサイトには未対応。

さくらインターネットは、IPv6推進していますとかいいながら、サイトはIPv6に非対応。
以前は対応していたのに、ころころとDC内ごろつきをしはじめてから、非対応になった。

今や、腐ったSaaSesで使われていた日本ラッドの IPアドレスまでのっとって、コーポレートサイトにつかっていてちょっとワロタ。元ライバルだったよね。 意味ありなかんじでIPアドレスを使っている。だが、IPv6には非対応。ウケる。
ちなみに、ここも 主要サービスすべてにIPv6対応していると、公言している。

$ host www.sakura.ad.jp
www.sakura.ad.jp is an alias for site-112800350116.gslb3.sakura.ne.jp.
site-112800350116.gslb3.sakura.ne.jp has address 163.43.24.70

 まとめ:

IPv6事業を積極的にやりますと宣言している事業者の多くは、WebサイトをIPv6対応にしているが、Topページがちゃんと閲覧出来ないところ、検索窓が動かないところが多く見受けられた。
また、最悪な例としては、直接サイトから絶対パスで呼び出す外部リンクの一部(主にCSSや画像、JavaScript等)の参照先サーバーが、IPv6にそもそも対応していないという悲しいことが発生。
中途半端なことをするぐらいなら、Reverse Proxyなどしかけて工夫すればよいのだが、一切ケアできていない。
ログインをしなければいけないなど、作り込んだサイトは仕方ないとしても、見せ方には工夫の余地がある。

少なくとも、サイトのコンテンツの一部(除外部サイトへのリンクや、別サービスのリンク)以外は、全部IPv6に対応させる必要がある。非常に優秀だと感じたのは、NTT東西フレッツネクストのIPoEサービスを始めるに当たって、名乗り出たVNE 3社の対応は素晴らしいとおもう。

また、IPv6アクセス時には、IPv6でアクセスしているとわかるようなロゴを掲載しているサイトは比較的まともな運用をされているように感じる。

[ コメントを読む(0) | コメントする ]

2017年08月17日(木) [晴れ]

[Network][Internet] JPNICにいきなり押し寄せて、現金ニコニコ払いでしてきたよ

今年の5月末、支払期限間近のタイミングの出来事。
とあるイベントでJPNICに訪問する機会(JPNICが会場を提供している)があり、訪問。
近くにJPNICの中の知り合いの方が通りかかったので、

「ちょっとお願いがあるんだけど、維持費を現金でもってきたので、支払いたいんだけど!」

と引き留めたところ、ちょっとまってね〜。とニコニコ。
そうしたら、いつもおなじみのIP事業部のお兄さん(JANOGとかよくいらっしゃる方)と経理の方を連れてきました。
多少時間はかかったモノの、領収書を発行し、現金ニコニコ払い、手渡しが出来ましたw

もちろん、こういう突撃なので、おつりが一切でないようにきっちり金額を持参。
事前にアポをとっておくと、ダメですといわれそうなので、突撃です。これで、振込手数料432円が浮きました。

請求書

請求書もフォーマットがおかしいですね、個人なのに、会社名のところに名前をいれているのか、敬称が無い。 その上で、担当者様。ちょっと、個人宅には、経理担当などはいません。あ、既婚なら、お金を管理する奥様はいるかも、、、、だが、私は独身だ!(笑)
そして、その後、名前。。よくわからず。という突っ込みをいれたら、「個人はあなただけだから勘弁してよ〜」と言われてしまいました。

無事、領収書発行。



領収書はテンプレをベースに個別に作成するので、宛名などちゃんとつくられていますね。
やはり、システム的なモノは個人を対象にしていなさそうでした。

ということで、仕事は増えるかもしれないけど、元々発生していなかった維持費。仕事を作って請求しているようなものだし、別にいいよね。てことで、現金払いが無事出来ました。
現金もって、突撃したのはあなただけですよといわれました。うん、いいの。実績出来ました。現金ニコニコ払いはOKですよ!

[ コメントを読む(0) | コメントする ]

2017年08月14日(月) [晴れ]

[遊び] 奈良県曽爾村 第22回曽爾村ぬるべの郷夏まつり

今年も花火をみに、夏祭りに行きました。
家から40分ぐらい、気温も22度と8〜10度程度近くとても過ごしやすい環境で、のんびりとしました。

昨年、ここでいただいた焼き鳥がとてもおいしく、1本100円、大行列という感じでしたが、今年もいただきました。
炭火で丁寧にやいており、柔らかく、1本もそこそこ大きく、満足。私は運転をしているので、クーラーボックスにノンアルコールビール、証明、椅子、ブルーシート、三脚と準備して花火を楽しみにしながら花火を楽しんでいました。

花火の規模は1000発程度と小さいですが、ほぼ目の前で打ち上げられ、のんびりと花火を見ることができます。 駐車場もトイレも完備、それほど混雑も無く、数百人程度。これほどよいのはなかなかないかもしれません。

てことで、比較的上手に撮れた写真を数枚掲載。あー、来年もまたいこうかな。















打ち上げ頻度もも密度が高くないので、煙で花火が見えなくなるということも余りません。
個人的には、30分ではなく、45分で、1500発程度、もしくは、1時間で2000発ぐらいでやってくれたらいいのになー、とおもいますが、小さい夏祭りですので、仕方ないかな〜。


ちなみに今回は、全開は28mmフルサイズのレンズを持ち込んで実質、40m近くなり、まったく撮影できませんでしたので、今年は、17mmのレンズを持ち込みました。それでも近い。。今回は、装備2台持ちで、一台はαで動画撮影、一台は一眼で写真をとりました。
三脚台に乗せる2台用アダプタを取り付け、αと一眼の2台置き、連動です。

来年からこの装備でいこうかなー。
花火を撮影するのは難しいので、本当に練習とコツが必要ですね。次回も頑張ってみます。

動画はYouTubeにあげてみました。


1:50秒ぐらいから素敵なかんじです。
[ コメントを読む(0) | コメントする ]

2017年08月13日() [晴れ]

[Network] CactiでDellスイッチやPanasonicのスイッチが64bit counterでトラフィック量が取得出来ない

DELL PowerConnect 5324を7, 8年ほど前から使っている。 なぜか、当時から64bit counterでちゃんとデータがとれずに困っていたが、アクセス回線が100Mbpsでありかつ、あまり負荷が無かったため、データのとれる32bit counter で値をとっていた。
今回、Bフレッツファミリー100が終了に伴いフレッツネクストファミリー隼へ移行することになり、現在2回線。
負荷試験でいじめるにしても、ifstatなどでリアルタイムモニタをするしかなく、グラフで値が取得出来なかったので、まじめに原因を調べた。最初疑ったのは、Cactiの環境の問題かと思いきや、どうやら違う。

tcpdumpをしながら、64bit counterでどのMIBを叩くかなど確認しながら行き着いた結果は、スイッチが原因。

32bit counter時

.1.3.6.1.2.1.2.2.1.16 IF-MIB::ifInOctets

64bit counter時

1.3.6.1.2.1.31.1.1.1.6 IF-MIB::ifHCInOctets

試しにAlaxalAのスイッチで実験。これが正常。

$ snmpwalk -v2c -c xxx 192.168.80.xx .1.3.6.1.2.1.2.2.1.16
IF-MIB::ifOutOctets.1 = Counter32: 1516
IF-MIB::ifOutOctets.3 = Counter32: 0
IF-MIB::ifOutOctets.10 = Counter32: 1487112571
IF-MIB::ifOutOctets.11 = Counter32: 2456434929
IF-MIB::ifOutOctets.12 = Counter32: 3346849069
IF-MIB::ifOutOctets.13 = Counter32: 4132961252
IF-MIB::ifOutOctets.14 = Counter32: 4194669011
IF-MIB::ifOutOctets.15 = Counter32: 3774590644
IF-MIB::ifOutOctets.16 = Counter32: 3056671465
IF-MIB::ifOutOctets.17 = Counter32: 3530654755
IF-MIB::ifOutOctets.18 = Counter32: 3422319366
IF-MIB::ifOutOctets.19 = Counter32: 3198503144
IF-MIB::ifOutOctets.20 = Counter32: 2603936208
IF-MIB::ifOutOctets.21 = Counter32: 2188571600
IF-MIB::ifOutOctets.22 = Counter32: 1012100246
IF-MIB::ifOutOctets.23 = Counter32: 4262057869
IF-MIB::ifOutOctets.24 = Counter32: 306827950


$ snmpwalk -v2c -c xxx 192.168.80.xx 1.3.6.1.2.1.31.1.1.1.6
IF-MIB::ifHCInOctets.3 = Counter64: 0
IF-MIB::ifHCInOctets.10 = Counter64: 25569802183641
IF-MIB::ifHCInOctets.11 = Counter64: 254264225399
IF-MIB::ifHCInOctets.12 = Counter64: 1731910044921
IF-MIB::ifHCInOctets.13 = Counter64: 102135098057
IF-MIB::ifHCInOctets.14 = Counter64: 29005642362472
IF-MIB::ifHCInOctets.15 = Counter64: 7648801206204
IF-MIB::ifHCInOctets.16 = Counter64: 6830172184232
IF-MIB::ifHCInOctets.17 = Counter64: 15829343
IF-MIB::ifHCInOctets.18 = Counter64: 210465854534
IF-MIB::ifHCInOctets.19 = Counter64: 1865576387531
IF-MIB::ifHCInOctets.20 = Counter64: 2153968856761
IF-MIB::ifHCInOctets.21 = Counter64: 1120854776316
IF-MIB::ifHCInOctets.22 = Counter64: 1900766547462
IF-MIB::ifHCInOctets.23 = Counter64: 154432887612
IF-MIB::ifHCInOctets.24 = Counter64: 252176593

問題のあったDELLのスイッチではどうだろうか。

$ snmpwalk -v2c -c xxx 192.168.0.xx .1.3.6.1.2.1.2.2.1.16
IF-MIB::ifOutOctets.1 = Counter32: 1499571481
IF-MIB::ifOutOctets.2 = Counter32: 321711521
IF-MIB::ifOutOctets.3 = Counter32: 0
IF-MIB::ifOutOctets.4 = Counter32: 1875939512
IF-MIB::ifOutOctets.5 = Counter32: 4191135883
IF-MIB::ifOutOctets.6 = Counter32: 0
IF-MIB::ifOutOctets.7 = Counter32: 128224061
IF-MIB::ifOutOctets.8 = Counter32: 119541184
IF-MIB::ifOutOctets.9 = Counter32: 127963818
IF-MIB::ifOutOctets.10 = Counter32: 0
IF-MIB::ifOutOctets.11 = Counter32: 169218862
IF-MIB::ifOutOctets.12 = Counter32: 3506523126


$ snmpwalk -v2c -c xxx 192.168.0.xx 1.3.6.1.2.1.31.1.1.1.6
IF-MIB::ifHCInOctets = No Such Instance currently exists at this OID

全ポートGigabit対応スイッチで、64bitカウンタに対応していないとはさすがに思わなかった。
さすがに、ネットワークメインじゃ無いメーカーが手を出すとこういう問題が発生すると言うことだろうか。困った困った。
ちなみに同一の問題が、Panasonicのスイッチでも発生している。

$ snmpwalk -v2c -c xxx 192.168.80.xxx system
SNMPv2-MIB::sysDescr.0 = STRING: <M16eG-Version1> System Software Release: 1.0.0.148
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.396.5.4.2.10
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (3885301964) 449 days, 16:30:19.64
SNMPv2-MIB::sysContact.0 = STRING:
SNMPv2-MIB::sysName.0 = STRING: sw2.tokyo


$ snmpwalk -v2c -c xxx 192.168.80.xx 1.3.6.1.2.1.31.1.1.1.6
IF-MIB::ifHCInOctets = No more variables left in this MIB View (It is past the end of the MIB tree)
$

この問題に気づき、ぐぐったら、フォーラムに同様の書き込みがあった。これは、原因が明確にわかっていないと検索出来ないたぐい。Broadcomのチップが対応していないと言いたいのかな? PCT5324 64bit SNMP

There are no plans to add support for the 64-bit HC counters. I believe this is a limitation of the ASIC, so a firmware update would not be able to add this support.

さらに見つけたのが、導入した後の話。。

I believe 5324 2.x.x.x firmware has 64 bit counters. It's on their website.
I've just installed the 2.x firmware and I can confirm the 64 bits counters!
Confirmed here as well. Yipee

動くのか動かないのか。ここからはわからず。

ちなみに、ファームウェアは次のバージョン。

NARA-PC5324# show ver
SW version      1.0.0.45 ( date  07-Jun-2004 time  14:34:51 )
Boot version    1.0.0.21 ( date  10-Aug-2004 time  13:33:06 )
HW version    00.00.02

Dell PowerConnect 5324, v.boot1.0.2.02/fw2.0.1.4, A06を見る限り、Last Updated 03 Nov 2011 らしいので、実はいけたりするのかな。

いしても、ネットワーク専門じゃないメーカーを買うとはまるという罠はここに。
ニュースには、 デル、大規模ネットワーク向けスイッチPowerConnect 5324を発売とあるんだけどなー。でも、所詮この程度。

ちなみに、この機器は、2013年6月27日にuptimeを見たとき次の値。そして、今年の8月7日にVLAN設定を変更していたら、応答が無くなりリブートした。

PC5324# show system
System Description: Ethernet Switch
System Up Time (days,hour:min:sec): 696,23:54:15

計算すると、約2200日連続稼働。記憶によると導入したのが、2007年頃。約10年ぐらい連続稼働しているので、そろそろお役御免なのかもしれません。

ということで、ファームウェアを更新してみました。

更新前:

NARA-PC5324# show version
SW version      1.0.0.45 ( date  07-Jun-2004 time  14:34:51 )
Boot version    1.0.0.21 ( date  10-Aug-2004 time  13:33:06 )
HW version    00.00.02
NARA-PC5324#

更新後:

NARA-PC5324# show ver
SW version    2.0.1.4 ( date  01-Aug-2010 time  17:00:12 )
Boot version    1.0.2.02 ( date  23-Jul-2006 time  16:45:47 )
HW version    00.00.02
NARA-PC5324#

更新が完了したので、試してみましょうか。

$ snmpwalk -v2c -c xxx 192.168.0.xxx 1.3.6.1.2.1.31.1.1.1.6
IF-MIB::ifHCInOctets.1 = Counter64: 8278680
IF-MIB::ifHCInOctets.2 = Counter64: 0
IF-MIB::ifHCInOctets.3 = Counter64: 0
IF-MIB::ifHCInOctets.4 = Counter64: 847869
IF-MIB::ifHCInOctets.5 = Counter64: 6184210
IF-MIB::ifHCInOctets.6 = Counter64: 0
IF-MIB::ifHCInOctets.7 = Counter64: 0
IF-MIB::ifHCInOctets.8 = Counter64: 0
IF-MIB::ifHCInOctets.9 = Counter64: 0

とれるようになりました.... ふむ。。。

ちなみに、リリースノートには本件に関する内容の記載はありませんでした。。。しょんぼり。

[ コメントを読む(0) | コメントする ]

2017年07月30日() [晴れ]

[TV] 「君の名は。」4K Ultra HD Blu-ray同梱5枚組 発売されたので、買いました!!

しばらく放浪の旅をしており、このときは福島。
Amazonで注文したら、27日〜29日といわれ、ホテルに送るにしても、29日には出てしまう。 もし、29日に到着すると受け取れない、どうしようか。という事であきらめて、予定を組んで局止めで取りに。
ヨドバシとか店舗で買おうかな?とおもったら、ポイント還元を計算しても、Amazonの方が安かった。

そもそも、4K Ultra HD対応の製品を調べてみたところ、ほとんど今年に入ってからプレイヤーが発売。
PS4が対応しているかな?対応していたら、PS4買おうかな?とおもったら、対応している、対応していないといういろんな情報が錯綜していて、開発段階では二転三転したようで、結果、仕様には対応と記載がなかった。理由としては、SONYがプレイヤーを出す前に、コンシューマー向けゲーム機、PlayStation4が4K Ultra HDに対応することが問題だったのではないかという推測の書き込みなどがみられた。

ちなみに、メディアの規格としては、BD-XL となるので、ここんところ数年で購入したBD Driveであれば、対応可能だろう。メディアとして対応できるが、再生環境としては、4K Ultra HD は、第7世代 Intel CPU(Uモデルをのぞく)なので、まだまだ、PCでの再生は難しい。最新のPCでも相当条件が厳しそうだ。

このパッケージには、通常のBlue-Rayも同梱されている、特典ディスクもついている、4K BDもついているという至れり尽くせりで、アフレコ台本までもついていました。

しおりは、、、、おっぱいもみもみのシーンではなく、その後でしたw

[ コメントを読む(0) | コメントする ]

2017年05月15日(月) [晴れ]

[Neta][Security] 悪質な詐欺サイトに引っかかりそうになった件

妹とやりとりしていた昨年末のこと。

私が家の中や車の中で使っている ロゴス 寝袋 ミニバンぴったり寝袋・-2(冬用)[最低使用温度-2度] 72600240をみて、こんな事言ってきた。

「東京の友達の家に泊まりに行ってディスニーランドに行くんだけど、布団がないので、あの寝袋、使い勝手がよかったのをみて、同じのがほしいの。通販でかって、直接友達の家に送りつけてそのまま持って帰ればいいかなって。ネットで探したら、高い! で楽天も安くないし、いろいろと探してみたんだけど、ここの通販、安いんだけど、ドメインが日本じゃなくて、怪しいんだけどどうなんだろう?」

「whoisしたら、ドメインは中国で、サーバーがトルコにあるし、SSLで暗号化もされなくて怪しい。特定商取引法に基づく表記というか会社情報をみたら、実在するんだよね。でも怪しくてかっていいのかわかんない。。。」

というこんなやりとり。


私はオフシーズンにセールで買ったので7500円ほどだったけど、今は、14,000円ぐらいするみたい。
ってことで、おもしろい事を聞いてきたので調べてみました。

ドメイン: bestbenefitsnursing.win [162.218.178.186]
$ whois bestbenefitsnursing.win
Domain Name: bestbenefitsnursing.win
Domain ID: D4301390-WIN
WHOIS Server:
Referral URL: www.west263.hk
Updated Date:
Creation Date: 2016-12-24T02:35:10Z
Registry Expiry Date: 2017-12-23T23:59:59Z
Sponsoring Registrar: West263 International Limited
Sponsoring Registrar IANA ID: 1915
Domain Status: ok https://icann.org/epp#ok
Registrant ID: C4296931-WIN
Registrant Name: jin tian 2 0 1 6
Registrant Organization: jin tian 2 0 1 6
Registrant Street: An Yi Xian Feng Huang An Ji Hua Yuan Xiao Qu
Registrant Street:
Registrant Street:
Registrant City: Nan Chang An Yi
Registrant State/Province: JX
Registrant Postal Code: 330507
Registrant Country: CN
Registrant Phone: +86.18956239563
Registrant Phone Ext:
Registrant Fax: +86.18956239563
Registrant Fax Ext:
Registrant Email: 123@byselljp.com
Admin ID: C4296932-WIN
Admin Name: Chen Yi Ming jintian
Admin Organization: Chen Yi Ming jintian
Admin Street: An Yi Xian Feng Huang An Ji Hua Yuan Xiao Qu
Admin Street:
Admin Street:
Admin City: Nan Chang An Yi
Admin State/Province: JX
Admin Postal Code: 330507
Admin Country: CN
Admin Phone: +86.18956239563
Admin Phone Ext:
Admin Fax: +86.18956239563
Admin Fax Ext:
Admin Email: 123@byselljp.com
Tech ID: C4296933-WIN
Tech Name: Chen Yi Ming jintian
Tech Organization: Chen Yi Ming jintian
Tech Street: An Yi Xian Feng Huang An Ji Hua Yuan Xiao Qu
Tech Street:
Tech Street:
Tech City: Nan Chang An Yi
Tech State/Province: JX
Tech Postal Code: 330507
Tech Country: CN
Tech Phone: +86.18956239563
Tech Phone Ext:
Tech Fax: +86.18956239563
Tech Fax Ext:
Tech Email: 123@byselljp.com
Name Server: ns5.myhostadmin.net
Name Server: ns6.myhostadmin.net
DNSSEC: unsigned

おもしろそうな事案だなっ!とおもい、ページを見てみると、妹がいってる会社情報と異なる。なぜ?
何度リロードしても結果は変わらないけど、環境をかえると、会社情報が異なる。
判断基準は、IPアドレスのみで、Cookieでは変化ありません。









現在は上記DNSから名前解決はできないが、hostsファイルに書いてみると確認できると思います。
さらに、見つけてみましたw
ここも偽物サイトの犯罪、詐欺サイトです。
ただし、サーバーの設定で、www.がURIに含まれているとすべて表示する設定となっていました。
wwwが無しであれば、下記のように返します。

$ telnet 162.218.178.186 80
Trying 162.218.178.186...
Connected to .
Escape character is '^]'.
GET / HTTP/1.1
HOST: example.com

HTTP/1.1 301 Moved Permanently
Date: Tue, 16 May 2017 13:20:45 GMT
Server: Apache/2
Location: http://www.example.com/
Content-Length: 230
Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="http://www.example.com/">here</a>.</p>
</body></html>

ということで、該当するドメインを探し出してみました。
Google先生に聞くといろいろと情報が出てきます。

162.218.178.186   www.attractivejp.trade             [162.218.178.186]
162.218.178.186   www.attractivejp.online            [NO RECODE]
162.218.178.186   www.badminwebnt.info               [NO RECODE]
162.218.178.186   www.brdjacket.online               [NO RECODE]
162.218.178.186   www.brdjacket.info                 [NO RECODE]
162.218.178.186   www.badminwebnt.info               [NO RECODE]
162.218.178.186   www.storagedomainmo.top            [NO RECODE]
162.218.178.186   www.exbrsedjacket.win              [NO RECODE]
162.218.178.186   www.beautifulmethod.info           [NO RECODE]
162.218.178.186   www.betterlifeye.info              [NO RECODE]
162.218.178.186   www.bestbetterlife.win             [NO RECODE]
162.218.178.186   www.lapdomainjp.top                [NO RECODE]
162.218.178.186   www.toysdomain.top                 [NO RECODE]
162.218.178.186   www.exbenenewsnursing.win          [NO RECODE]
162.218.178.186   www.cheapbadmintonset.win          [NO RECODE]
162.218.178.186   www.betterlifevip.win              [NO RECODE]
162.218.178.186   www.vipbabyhappy.win               [NO RECODE]
162.218.178.186   www.vipbrandjacket.win             [NO RECODE]
198.55.31.173    www.totebagvipby.win               [192.168.8.8] ... 書き換えられている
198.55.31.173     www.antitheftsummer.bid            [198.55.31.173]
198.55.31.173     www.beneficialwebbody.info         [NO RECODE]
198.55.31.173     www.contactlensesautumn.info       [NO RECODE]
198.55.31.173     www.musicalinstrumentsnorth.info   [NO RECODE]
198.55.31.173     www.byvenetianblind.win            [192.168.8.8] ... 書き換えられている
198.55.31.173     www.toyokstore.win                 [192.168.8.8] ... 書き換えられている
198.55.31.173     www.musicalinstrumentsnorth.info   [NO RECODE]
192.151.159.154   www.motorsbag.win                  [NO RECODE]

WHOISを引いてみました。

$ whois attractivejp.trade
Domain Name: attractivejp.trade
Domain ID: D3D4C2D256C8C42E4853A8465A8B868BF-NSR
WHOIS Server: whois.west263.com
Referral URL: West263.com
Updated Date:
Creation Date: 2017-05-10T09:06:34Z
Registry Expiry Date: 2018-05-10T09:06:34Z
Sponsoring Registrar: Chengdu West Dimension Digital Technology Co., Ltd.
Sponsoring Registrar IANA ID: 1556
Domain Status: ok https://icann.org/epp#ok
Domain Status: addPeriod https://icann.org/epp#addPeriod
Registrant ID: CE82F7C60A1DD4CB192573B406229E124-NSR
Registrant Name: wu yue ba
Registrant Organization: wu yue ba
Registrant Street: Zhang Jia Kou Feng Huang Cun 697hai
Registrant Street:
Registrant Street:
Registrant City: zheng zhou
Registrant State/Province: HA
Registrant Postal Code: 452471
Registrant Country: CN
Registrant Phone: +86.15896235689
Registrant Phone Ext:
Registrant Fax: +86.15896235689
Registrant Fax Ext:
Registrant Email: 123@byselljp.com
Admin ID: C459712B12D684CEBBE7860F91F61DD9A-NSR
Admin Name: yueba wu
Admin Organization: yueba wu
Admin Street: Zhang Jia Kou Feng Huang Cun 697hai
Admin Street:
Admin Street:
Admin City: zheng zhou
Admin State/Province: HA
Admin Postal Code: 452471
Admin Country: CN
Admin Phone: +86.15896235689
Admin Phone Ext:
Admin Fax: +86.15896235689
Admin Fax Ext:
Admin Email: 123@byselljp.com
Tech ID: C50DB5DF2B8B94C0BAFB8B9CE02E8D22F-NSR
Tech Name: yueba wu
Tech Organization: yueba wu
Tech Street: Zhang Jia Kou Feng Huang Cun 697hai
Tech Street:
Tech Street:
Tech City: zheng zhou
Tech State/Province: HA
Tech Postal Code: 452471
Tech Country: CN
Tech Phone: +86.15896235689
Tech Phone Ext:
Tech Fax: +86.15896235689
Tech Fax Ext:
Tech Email: 123@byselljp.com
Name Server: ns4.myhostadmin.net
Name Server: ns3.myhostadmin.net
DNSSEC: unsigned
>>> Last update of WHOIS database: 2017-05-15T04:47:17Z <<<

2つのwhoisを比べてみると、

Tech Email: 123@byselljp.com
West263.com
162.218.178.186

が共通のようです。

いろいろと調べてみると、 国税庁法人番号公表サイトで法人番号と実在する企業情報が入手可能であり、一括で情報のダウンロードも可能です。
噂によれば、実在する法人リストを入手し、会社情報をランダムに表示しているのではないかと考えられます。

この偽物犯罪系通販サイトで装っている商品の価格は、実際に特価や特売であり得る範囲のもので、2万円以下程度のモノが多く、怪しいと思っても巧妙に作られているため、だまされてしまうようです。 気づくには、カード決済なのに、SSLで暗号化されない、WHOIS情報が怪しい、サーバーが海外にあるといったところから総合して判断するしかなく、ぱっと見た限りでは、本物と区別が付きません。会社は実在していますが、勝手に悪用された会社情報であり、ランダムに出てくるだけです。その会社が通販をしているような組織ではなく鉄工所だったりと、怪しいところはありますので、表示される会社と事業が一致しているかどうかなども見分けのポイントかとおもいます。

皆さんも気をつけましょう。

ななし  『いつも拝見しています。 同じような詐欺サイトに引っかかり、内容証明/口座凍結等の対応をしていますorz SSLの暗号化がされてない所やクレジットカード決済の明記があるのに、 何故か銀行振込のみの対応で「?」と思いつつ振り込んだのが間違いでした。 ちなみに、 >ということで、該当するドメインを探し出してみました。 >Google先生に聞くといろいろと情報が出てきます。 との事ですがどうやってIPアドレスから紐づくドメインを出されていますか.?』
[ コメントを読む(1) | コメントする ]

2016年12月01日(木) [晴れ]

[TV][Neta][Security] ドクターX 第8話 で 標的型攻撃メールのシーンが!でも、ドメインがひどい。

ドクターX シーズン4 第8話(12月1日放送)のシーンで、標的型攻撃のシーンがあった。

内科部長の黄川田(生瀬 勝久)が怪しいファイルを開いたのか、なにか踏んでしまったようだ。

黄川田「あれ?え?なにこれ?ファイルを開けませんって。誰か俺のパソコンさわった?」
内科医「さわってません」
内科医「自分もさわってません」
黄川田「おかしいじゃないの、昨日まで使えてたのに。いや、正直にいったら怒んないから。誰?本当に誰もいないの?」
とうシーン。



黄川田がなにか踏んでしまい、その後メールをばらまいてしまったという流れだろうか。



「極秘配達終了しました。ありがとうございました。」というメッセージ。



明らかに標的型攻撃でねらわれた一シーンであった。
それはよいのだが、ここで使われている、t_kikawada@toutei.co.jp というメールアドレス。
whoisしてみると、実在するドメインであることがわかる。

whois toutei.co.jp

$ whois -h whois.jprs.jp toutei.co.jp

Domain Information: [ドメイン情報]
a. [ドメイン名]                 TOUTEI.CO.JP
e. [そしきめい]                 かぶしきがいしゃ はまのほてる
f. [組織名]                     株式会社 浜のホテル
g. [Organization]               Hama no Holte Inc.
k. [組織種別]                   株式会社
l. [Organization Type]          Corporation
m. [登録担当者]                 HT3398JP
n. [技術連絡担当者]             YM21548JP
n. [技術連絡担当者]             YN10246JP
p. [ネームサーバ]               dns101.wadax.ne.jp
p. [ネームサーバ]               sv109.wadax.ne.jp
s. [署名鍵]
[状態]                          Connected (2017/05/31)
[登録年月日]                    2000/05/30
[接続年月日]                    2000/05/31
[最終更新]                      2016/06/01 01:07:55 (JST)

その後ウィルスに感染し、北野先生によるプロジェクションマッピング技術を使用した手術を行う際、北野先生のパソコンにウィルス感染。
手術中にプロジェクションマッピングのシステムが停止、手術ができなくなるというシーンだ。

うーん。。。
そもそも論として、手術に使う機材を部員のノートPCで実施するというシーン自体がシナリオ上おかしくないか、普通は専用端末ではないのか。という疑問も残る。また、ネットワークを隔離していないというのもそういうのもなのか?という点。でも、実際現場はこういうレベルである可能性も高く、警鐘を鳴らしている可能性も考えられる。

それにしても、こういう番組が、実在するドメインを使用していいのか。
そもそも論として、co.jpではなく、なぜ、or.jp や 大学病院なので、 ac.jp ではないのか。
属性型・地域型JPドメイン名によると、

OR.JP 	以下の法人組織が登録できます。

    財団法人、社団法人、医療法人、監査法人、宗教法人、特定非営利活動法人、特殊法人など
    農業協同組合、消費生活協同組合など
    国連等の公的な国際機関、国連NGOまたはその日本支部
    外国政府の在日公館など

AC.JP 	高等教育機関、学術研究機関などが登録できます。

    大学、大学校、高等専門学校、大学共同利用機関などの学術研究機関
    学校法人、職業訓練校、職業訓練法人

このケースだ、ac.jp が適切なはず。あー、やらかしてしまった系のドラマシーンでありました。
JPRS が何か、こういうケースに対してアナウンスを出すとおもしろいな。
ね? @OrangeMorishita さんっ!
テレビ番組がドラマに使う都合の良いドメインとかなにかあるといいんだけどねw
勿論ちゃんと押さえるというのもありですけど。(属性ドメインだといろいろと難しいが)

ちなみに、toutei.co.jp ドメインは、「 株式会社 浜のホテル」が現在保有しています。
静岡県下田市にある 伊豆下田・入田浜 浜辺の宿 濤亭ホテル。 何か、朝日テレビと関係があるのだろうか?気になるこの頃でありますね。

ということで、提案だ!ドメイン絡みでRFCをかけばいいんだ。
テレビ番組とか書籍で使うための実在する組織では使えない、インターネットでは引けない予約gTLDを定義すればいいのだ!
予約ドメインとして、example.com などはあるけど、番組で使うにはあからさま杉なので、このケースでは、toutei.ac.jp.hoge てきな何か。

[ コメントを読む(0) | コメントする ]

2016年07月22日(金) [雨]

[Computer] archive.org 月刊 I/O アイ・オー

超なつかしすぎる。私が生まれてない時代のもあるけど。

[ コメントを読む(0) | コメントする ]

[Network][Life][Other] Pokemon Go を使いたければ、NAT環境はすべて規約違反になるのか?

本日めでたく、Pokemon Goが配信されました。早々にインストールして気になっていた規約を読むと...

一言で要約すると、Pokemon Go の利用規約の禁止事項には、「TCP/IP ... ヘッダ情報の一部を偽造し、又は、何らかの方法で本サービス ... 改変・偽造された、又は不正なソース特定情報」とあるので、NAT/CGNはアドレス、ポート変換がされるので、改変(not偽造)に当たるぞ。3大キャリアや、ブロードバンドルータ、モバイルルータでは規約、しかも禁止事項に抵触するぞ!使っちゃだめだぞ!(かなり強引)

じゃあ、どうやってプレイするんだよ、それは、グローバルIPを付与するキャリア以外のMVNO SIMを契約しろよ!ってことだろうね(かなり強引)。

これで、MVMOブームがやってくるっ!(きっと...)

ということで、解説。

もともと 利用規約を読んだ理由は、ingressと同時プレイはアウトかどうかが気になっただけなのですが、それよりも気になったのは下記の通り。

TCP/IPパケットヘッダ若しくはメールやニュースグループのヘッダ情報の一部を偽造し、又は、何らかの方法で本サービス若しくはコンテンツを利用して改変・偽造された、又は不正なソース特定情報を送信すること。

「TCP/IP ... ヘッダ情報の一部を偽造し、又は、何らかの方法で本サービス ... 改変・偽造された、又は不正なソース特定情報」とあり、 NAT(Network Address Translation/ネットワークアドレス変換)を使用した場合、IPパケットのヘッダの書き換えを行っている。一般にCGNやブロードバンドルータが実装しているのは、NAPT(Network Address Port Translation)であり、 IPアドレス変換だけではなく、ポート変換も行っているすなわちパケットのヘッダの書き換え、すなわち改変を行っている技術である(強引すぎ?)。

よって、ポケモンGoをつかいたければ、キャリアSIMは規約違反になるし、多くのホットスポットで使うこと、モバイルルータ経由でつなぐのも規約違反、禁止事項に該当するのではないかと考えられる。

ただし、ソフトバンク系が提供している一部のmobilepointおよびそのローミングは、IPv4のグローバルIPを付与しているので、NATは使われていないと思うので、問題ないだろう。間に何が入ってるか不明だが...

次に、トンネリング技術やVPN技術を使用した場合、「又は不正なソース特定情報を送信」というのが、引っかかるのではないか。なぜならば、ソース特定情報とは、明確に誰もがわかるように書いていないが、 GeoIP(IP Geolocation)のことではないかな、と思います。すなわち、IPアドレスによる位置情報を検索しているので、VPNやトンネリングを使うと、単一のIPアドレスをどこでも使えるようになりますが、これも禁止しているとなると、フレッツなどのPPPoEもアウトではないかと。

すなわち、許されるのは、トンネリングやpppを使わない、IPアドレスでないといけないとなると、専用線やEthernet接続がされているものでなければならないと仮定すると、モバイル端末はすべてアウトなのではないかと。その回線上でつながった、Wi-Fiでしかプレイできないということになる。(結構強引?)

ソースという意味で、ソースアドレスの書き換えという読み取り方をすると、NATとも読み取れる。

ま、後者については、かなり強引な解釈なので、こちらは無視するとしても、前者はアウトのように見えることから、NATを使う環境ではプレイできない。

グローバルIPを付与するSIMといえば、biglobeや、そのほかでは、固定IPを提供するISPなどしかわからない。

最近、三大キャリアである、ソフトバンクモバイル(含旧イーモバイル)、AU、ドコモ共にLSN(CGN)配下でプライベートIPである。IIJmioもNAT配下。

てことで、そもそもこの禁止事項が現代の状況にあってないので、明らかにおかしいよね。だって、ニュースグループって・・・。Pokemon Goってニュースグループって使ってるんですかね? あと、IPv4アドレスが枯渇といってるこの時代。

[ コメントを読む(0) | コメントする ]

2016年07月17日() [晴れ]

[IPv6][NTT][Internet][Network] IPoE + IIJmio + Transix + DS-Lite で実験

背景として、広域(東阪/奈)でネットワークが敷設してあり、Cisco WLCを導入し、Flex Connectで繋がっている。
Flex Connectを敷設してある拠点ではどこででも同じVLANにアクセス出来る構成となっている。

ちょっと早いが母の日にということで、iPad2をプレゼントしたので、それようのゲストWiFiを用意する必要が出来た。

ただ、既存のv4環境はVPNやDCなどと繋がっていたり、特定のサイトにアクセスが可能なネットワークとなっているため、そのまま出せない。 ip filterをすべてのサイトに対して実施するのは事実上困難であり、別の回線を用意するか、あいているグローバルIPでNATをして専用のネットワークを出すか、もしくは別途ISPを契約するしかなかった。また、友達が遊びに来た際、提供出来るネットワークも作りたかったので、環境を準備することにした。そのほかテスト用の端末や、大容量のサイズをダウンロードするときも高速なネットワークがほしいと思ったりもする。

そこで、既存の環境はそのままで、新たに Transix + DS-Lite の設定を用意すれば、別途ISPの契約もグローバルIPの消費もいらないという名案が浮かび上がり実装することにした。

ちなみに西の回線はBフレッツファミリー100なので、IPoEではないので、この方法は使えないので、東の環境で構築し、VLANをのばしたり、Flets Connectを使ったりして、西の方で提供、母親が使えるようにした。
環境は以下の通り。

Ciscoの設定は簡単で、下記のようにすればよい。このあたりは インターネットマルチフィード DS-Lite IPv4接続オプション接続確認機種情報Cisco 1812Jを参考にすればよい。

我が家では下記の通り設定した。
なお、2404:8E00::FEED:100 および 2404:8E00::FEED:101 はAFTRのアドレスだ。

 ! ONU
 ! track 100 interface GigabitEthernet0/5 line-protocol

 ! DS-LITE
 interface Tunnel1
  description MF-DS-LITE
  ip vrf forwarding guestnet
  ip address 192.0.0.2 255.255.255.252
  ip nat outside
  ip nat enable
  ip virtual-reassembly in
  tunnel source GigabitEthernet0/5
  tunnel mode ipv6
  tunnel destination 2404:8E00::FEED:100

 ! LAN IF
 interface Vlan100
  description TOKYO-GUESTNET
  ip vrf forwarding guestnet
  ip address 172.16.0.3 255.255.252.0
  ip nat inside
  ip virtual-reassembly in
  ip ospf shutdown
  ospfv3 shutdown
 ! vrrp 100 ip 172.16.0.1
 ! vrrp 100 timers learn
 ! vrrp 100 priority 90
 ! vrrp 100 track 100 decrement 254
 ip route vrf guestnet 0.0.0.0 0.0.0.0 192.0.0.1

これで、パフォーマンステストで1Gbpsぐらいの負荷をかけようとしたり、TCPセッションが何本はれるか実験をした。
そうすると、40Mbps程度しかでなく、おっせーなー、とおもいPPPoEの方が、200Mbpsぐらいでて早いじゃん・・・という無残な結果。

IIJのてくログには、 IIJmioひかりの混雑の理由とバイパス手段(IPoE・DS-Lite対応)にかいてある通り、DS-Liteのほうが早いという期待をしていたが、かなりガックシ。おっせーとおもい調べていたら、ルータのCPUが100%になっていることが判明し、このルータではないな、、、という無惨な結果。この結論はおいておいて、おもしろい遊びが出来るおもちゃを手に入れてしまったので、遊んで^H^H^H検証してみることにした。

sample configはこんな感じ。

interface Tunnel0
 description MF-DS-LITE
 ip address 192.0.0.2 255.255.255.252
 ip nat outside
 ip nat enable
 ip virtual-reassembly in
 tunnel source GigabitEthernet0/5
 tunnel mode ipv6
 tunnel destination 2404:8E00::FEED:101

interface Tunnel1
 description MF-DS-LITE
 ip vrf forwarding guestnet
 ip address 192.0.0.2 255.255.255.252
 ip nat outside
 ip nat enable
 ip virtual-reassembly in
 tunnel source GigabitEthernet0/5
 tunnel mode ipv6
 tunnel destination 2404:8E00::FEED:101

IPv6はvrfを切らず、ipv4だけ vrf をきった。
その上で、DS-Liteのtunnelを2つ作成、検証。

検証1: 何セッション使えるか(NATセッション数)

サーバー側にダミーのポートを準備、接続出来る状態にする。CE配下の各vrf毎に同一のサーバーにncでソケットオープンし、何個開けるか実験、サーバー側でnetstatの数を集計

結果:BR側の出口のv4アドレスはどちらも同じ、合計 1012 しか使えなかった。
ちなみに、AFTRは同じにしているが、別のケースは検証してない(いや、しろよ・・・ていうか、するべきだなぁ)

検証2: vmware上に構築したvyosでパフォーマンスおよびセッション数の検証および検証1環境と同時に使用
検証1では無惨な結果だったので、vmware上にvyosをあんちょこで展開し環境構築。でDS-LiteのCEを実装、5分ぐらいで出来た。
configは下記のような感じ。

set interfaces ethernet eth1 address '172.16.0.2/22'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 hw-id '00:0c:29:8d:07:92'
set interfaces ethernet eth1 smp_affinity 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces tunnel tun0 address '192.0.0.2/30'
set interfaces tunnel tun0 encapsulation 'ipip6'
set interfaces tunnel tun0 local-ip '2409:10:xx:xx::xx:xx:xx'
set interfaces tunnel tun0 multicast 'disable'
set interfaces tunnel tun0 remote-ip '2404:8e00::feed:100'
set protocols static interface-route 0.0.0.0/0 next-hop-interface 'tun0'

結果: 600Mbpsぐらいでた出る。
この状況で、Ciscoルータをゲートウェイに向けた端末と、vyosをゲートウェイに向けた端末を比べてみると、出口のv4アドレスが違うことが判明。セッションもおのおので独立していることから、CE側のIPv6のアドレス毎に決まるようで、prefixの割り当て毎にポート数が割り当てられるのではないようだ。
また、一定の間隔でTCPセッションを張りっぱなしにしておくと、出口のv4は変わらないが、通信が無くなり、しばらくセッションがいなくなると、次の通信の段階で出口のv4アドレスが変わっていることが判明した。こうやってアドレスを共有し、切りつめているようだ。

すなわち、Ciscoの遅いルータで環境を構築するぐらいならば、DS-Liteを実装したvm箱をたくさん用意すれば、高速な箱が完成、セキュアに独立したインターネット出口を用意できる。これは、案件や用件、利用者毎に準備すれば、回線を複数引かなくてもよく、独立したおのおののネットワークが構築可能だ。

また、フレッツ IPv6オプションを契約すれば、NTT東西はまたげないものの閉域網内で折り返し通信が可能。この上でIPv6 VPNを張り、代表となる回線にTransixやJPNEなどのIPoEを開通、DS-LiteやMAP-Eなどで出て行けば、1Gほぼフルに使えるISPができあがり。セッション数が足りなければ、違うIPv6アドレスでCEをつくればいくらでもセッション数は増やせる。増やした場合、ロードバランスするVMもしくは、ソースアドレスルーティングをして、内部でルータ振り分けをするルータを作れば完成。これで高品質な広帯域のインターネット接続が確保出来るという寸法。

ちなみに、IPoEのIPv6アドレスの固定は保証されていないものの実質固定。その中でルート的なサーバーを何台かに分散して持たせておけば、DDNS的なことも出来るだろう。ISPの契約も1つで、後は回線だけでよい。こういうおもしろいことも出来るおもちゃ。
こういう高品質の上にストレージネットワークを作ってもいいね。低レイテンシーだそいろいろと遊べそうだ。とおもったら、登君が 「OPEN IPv6 ダイナミック DNS for フレッツ・光ネクスト」サービスを公開というのを作っていた。ちなみにこのネタで遊んで他のはプレスリリースを出す前だ。考えることは同じだなぁ。


 まとめ:

まとめると次のような感じ。

テストをして遊んだ後、vyosがmaster、cisco(guestnet用vrfを作成)がbackupとして冗長、メンテナンスや障害時も無停止でメンテナンス出来るようにした。パフォーマンスは落ちるけど...

[ コメントを読む(0) | コメントする ]

[Network] 841Mをつかってみて

使っている環境は、IPv4(PPPoE, OSPF, vrf, NAT), IPv6(PPPoE, OSPFv3, vrf) という構成。vrfは自宅内にゲスト環境と仕事用の環境、プライベート環境が混在しており、特定のVLANはデータセンターに繋がってるとか、ルーティングされているといったものがあり、分けないといけないことから、vrfが必須になっている。元々複数のルータを使ったり、ACLでがんばっていたもののそろそろきつくなり、vrfを採用した。

フレッツでPPPoEを使っていると、NATセッションを酷使していない範囲では、200Mbps程度問題なく出る(フレッツのv4の上限なので問題ない)ので、パフォーマンスには特に問題ないが、一定の周期でRTTが大きくなり、1ms〜10ms強のジッターが発生する。

--- 192.168.XX.XX ping statistics ---
169 packets transmitted, 169 received, 0% packet loss, time 168439ms
rtt min/avg/max/mdev = 0.592/1.030/14.076/1.371 ms

おおよそ、30秒〜50秒程度の間隔なので、OSPFの周期ではないかと想像しているのだが、このジッターが実は結構不快感を肌で感じることが出来てしまいきつい。

また、DS-Liteを使った場合、CPUが張り付いてしまい、実効スループットは、40Mbpsも出ない。

[ コメントを読む(0) | コメントする ]

[Network][IPv6] Cisco 841M 15.5(3)M でIPv6の通信が不安定、原因は、ipv6 cef という可能性が濃厚

Ciscoサポートコミュニティーにも投稿されているが、この問題はコミュニティー上では解決せず、「サービスリクエストをオープンいただいた方がよいと思います。」という状況になっている。
同様の問題も構築中に発生し、IPv6 PPPoE でDial、SVIを数個切ってる。
DHCPv6で取得したSVI配下の端末から、ping6を送信すると、きれいに50%(2個に1つ)かならずロスするという問題があった。
いろいろと調査していく結果、Ciscoルータからpingを送信したばあいロスしない、ルータがSVIをまたいでフォワードするケースでパケットが50%きれいに落ちるという状況。

実は、cefが問題ではないかとおもい、下記のコマンドを投げた。

# no ipv6 cef
# ipv6 cef

そうすると、見事に回復。Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング) にバグがあるのが明確となった。さて、どうしたものか....とりあえずの work around はあるものの気持ち悪い。さあ、IOSを提供してもらおうかとおもうと、また、電話で・・・かよ。。とおもうと気が滅入る。ちなみに、My Ciscoには未だに保守登録がされておらず、ケースオープンが出来ません。よって電話で(ry

[ コメントを読む(0) | コメントする ]

[Network] Cisco C841M-4X-JSEC/K9 を導入したらドはまった。だって、データシートに書いてあるOSPFv3が動かないんだもの。という顛末。

家のネットワークが、IX2015 で 100Mであったこともあり、そろそろGigaにしたいなぁと。ちょうど、ヤフオクで大黒屋というところが、新品で出品していたC841Mを落札。このCisco Startシリーズは、最初から保守が2年込みがウリ。15kぐらい。買う前に、IPv6に対応していること、OSPFv3およびVRFに対応していることが条件だった。
いろいろとやりとりをしているウチに、後述する理由でデータシートなどを書き換えられてしまったので、とりあえず、当時の公開されていたスペックは下記を参照にしていただきたい。

INTERNET Watch: 誰のための日本語GUIなのか? 中小企業向け低価格ルーター「Cisco 841M J」( データシートミラー, スクリーンショット)

データシートでは、OSPFv3が使えるとある。ただし、BGP4+にはPDFのデータシートには対応と記載があるが、Webには未記載。
後者は謎であったが、今回対外接続でBGP/BGP4+でフルルート食べさせたりしないので、Advanced Security で 必要要件には十分であった。

実際に導入するべく、環境構築、検証してみると、OSPFv3が動作しない。
まず、環境は下記の通り。

#sh ver

Cisco IOS Software, C800M Software (C800M-UNIVERSALK9-M), Version 15.5(3)M, RELEASE SOFTWARE (fc1)

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*1        C841M-4X-JSEC/K9      FGLXXXXXX

License Information for 'c800m'
    License Level: advsecurity   Type: Permanent
    Next reboot license Level: advsecurity

OSPFv3の設定をいれてみようとすると、下記のようなエラーメッセージ。

(config)#router ospfv3 1
Protocol not in this image

(config)#ipv6 router ?

rip IPv6 Routing Information Protocol (RIPv6)

(config)#


(config)#int vlan XX
(config-if)#ipv6 ospf ?
% Unrecognized command

Protocol not in this image といわれ、このイメージ(C800M-UNIVERSALK9-M)では使えないといわれるので、シスコサポートコミュニティーの Cisco Startルータというコミュニティーに C841M-4X-JSEC/K9 で、OSPFv3を使いたいと投稿した。

それと同時に、固有の問題と考え、改めて、Amazon で Cisco Systems ギガビット対応VPNルータ C841M-4X-JSEC/K9/START【保守2年付】というのがあり、ぽちっとなと購入して検証してみたが、同じ挙動。


 保守登録ができない:

仕方なく、サポートコミュニティーに投稿しても応答がなく、しかたなく、ケースオープンをするため、保守登録をしようとすると、販売店は登録しないという。大黒屋は新品ということで購入したが、保守登録のしかたもわからないし返品の対応もしない、メーカーに聞けと一点ばり。Ciscoは販売店にいって、登録してくれという。行き詰まる。で改めてCiscoの回答を販売店に伝えると、大黒屋は販売店に聞けと何度も言う。 もう一点で購入した SMART1-SHOPも同じことを言う。エビデンスとして次のようなメールをもらった。

大黒屋

質問)
----
Cisco製品の場合は、新品の場合は、基本的に保守加入が必須となっておりますが、
手続きについて教えてください。
こちらで登録しようとした際できなかったので販売店から登録してもらう必要があります。

ソフトウェアについて、最新のものを提供をお願いいたします。
確認したところ、現時点で、

 c800m-universalk9-mz.SPA.156-2.T.bin

が最新のものとなっています。

また、OSPFv3の使用を前提で購入していますが、下記の内容には対応とありますが、
今回納品いただいたものでは使えませんでした。
ご確認いただけますか?
必要に応じてTACにあげる必要があると思いますので、保守情報をいただけないのであれば、
そちらで対応願います。


回答)
----
保守加入の件ですが未使用品の為、確認はしておりませんでした。
申し訳ございません。
また専門店でない為、今回の件はお手数ですがメーカーに
お問い合わせください。
万が一問い合わせされても解決されない場合はこちらの連絡掲示板に
ご連絡ください。
ご対応させて頂きます。
宜しくお願い致します。

やりとりをして返品を要求したが結果、データシートに記載事項が動かないが電源が入るといったニュアンスで、拒否。途中で返事が無くなった。

SMART1-SHOP - Amazon マーケットプレイス <XXXXXX@marketplace.amazon.co.jp> 

ご連絡頂きました保守登録につきまして、誠に申し訳ございませんが、
お客様にてご登録を行なって頂いておりますので、何卒ご了承頂きますよう、
宜しくお願い申し上げます。

なお、ご登録方法につきましては、下記メーカーサポートにて
ご案内をさせて頂いておりますので、ご利用下さいませ。

【Cisco Systems】

TEL 0120-092-255

平日 10:00〜12:00、13:00〜17:00

以上、大変お手数ではございますが、ご確認頂きますよう、
宜しくお願い申し上げます。

 保守登録は出来ないもののケースオープンは出来た:

こういう糞会社は排除すべき。ということで、晒しあげる。らちがあかなくて何度もやりとりしてて、ルータに不具合があるのか動かないので、困ってるといったら、保守の登録はしてないものの有効期限を確認しますとのことで、期間内。そりゃ、販売されてそんなにたってないし、購入して数日ですから。とにかく症状を伝え、チケットを切ってもらった。内容は、OSPFv3が動かない。どうしたら動くか?という内容。

そこから、問題解決まで1ヶ月ほど。。。中国人の対応がものすごく悪く、クレームをいれもしたが、やりとりの最中、いきなりガチャ切りするわ、名前を間違えるはで最悪。聞いてみると大連に飛ばしているらしく中国人。チケットでのエビデンスものこさず、電話ばっかりかけてくる。いや、こっち、現場作業員のOLだし、その場で確認できるわけでもないのに、今すぐ確認しろとか平気でいってくる。その割には記録としてチケットに残さない状態。もう、サポート最悪。

結局、その後、サポートの方も困ったらしく、商品担当にエスカレしたようで、FacebookのDMでともちゃ、あれの件だけど・・・僕商品担当。。。ということで、裏でやりとりしつつ・・・。えっと、とてもコストの高い知人が出てきてしまって焦る。ま、無事に解決して、全台保守交換となった。


 RMAで交換品はDHLで...:

交換品を送るときに運送会社を聞いても、中華野郎はわからないと。確認しますといって、最終的に判明したのは、DHL、ここから地獄の始まり。
DHLは平日にしか配送出来ない(=土日祝は不可)、時間指定も出来ないという。

末端作業員のOLの身としては、平日は家にいないし、平日時間指定出来ないといわれると、そもそも受け取りできない。会社に送るにしても元箱含めてでかいしむりだし、そういう場所でもない。
そして、中華の人はなぜ受け取れないのか理解出来ないという状況。

あいつらは仕事さぼればいいとでもおもってるのか、と喉から台詞が出てきそうになってしまう。
が、ぐっとこらえて、DHLでおくられたら一生受け取れないよ。誰かに受け取ってもらえないのかともいわれるけど、無理。一人と返す。

一人暮らしの寂しい末路を送ってる婚期を逃した生き遅れの私にはとうてい無理ってこと。相方仮にいてても、仕事してるだろうにw

そして、振り出しに戻り、配送業者から不在ですと連絡が入ったようで、電話。

「いつ受け取れますか?」

と会話が成り立たない。


 とりあえず六本木経由で佐川で送ってもらった&RMAで返送するのもDHLとか...:

んで、困って、ひとまず、商品担当の人に相談。そうすると、結局、六本木で受け取ってもらい、佐川急便で発送してもらうということに。
佐川急便は車で往復50キロ弱ドライブしたら24時間受け取れる集荷場があるので、それで送ってもらった。
ちなみにクロネコヤマト宅急便やゆうパックなどは19時、17時なのです。通勤片道2時間以上かかってるような田舎ものには受け取れません。

この時点で、保守部品到着後の返却期限がきていて、不良品はいつ返送してくれますか?と中華の野郎は電話してくる。

さすが交換品を受け取ってないのにそれはねーだろ。とブチ切れ寸前。そして、返送方法を確認してみると...

要約すると、「DHLに集荷の依頼をして、送り返せ、平日しか無理だ。受付は24時間WEBでできるけどな、ガハハハ」

という感じで、平日家にいねーっていってるだろと。深夜0時以降きてくれるならええぞといったら、出来ませんって。。

最終的に、使える運送会社でいいから送り返してくれってことになった。


 佐川の対応が今回はいつも以上に糞。わかってたけど。:

佐川急便で不在伝票がはいってたので、 電話をしたら、営業所はでない、自動音声。仕方なく24時間の営業所まで片道25kほど車でドライブしていくと、
一言目に、 事前に連絡くれました?探すのに時間かかりますよ。

だと。何度電話しても出なかったのはどこのだれですか?出ないんだったら繋がる番号を教えろいうが、教えれない。と返された。
相当殺意がわく。

そして、伝票を渡して、引き取るとき、身分証明出来るものをいわれたので、伝票と免許証でセットであって名前も書いてあるが、本人確認できない、住所確認ができないといって引き渡し拒否しやがる。1時間ぐらいもめてやっと引き渡し。その間、トラックがやってきて、Amazonの物流用のトラックだったようで、暇なので受付けエリアから写真をとりまくって、中を観察してじろじろとみて、Twitterにあげるw ぐずぐずするからだよ。んたく。
ちなみに、本人確認できない、住所確認できないとかいわれたの初めてです。伝票、同じ名前の免許証で。だったら、今から帰るから、その住所に持ってこいといったら出来ませんとさ。ほんまに佐川も糞。

やっと受け取り、交換、再設定。これで、IP Advancedとなりました。
解決の後、クロネコヤマト宅急便で深夜にコンビニに車で持って行って返送しました。


 その後、データシートが修正される:

その後、 シスコサポートコミュニティ C841M データシート訂正のお知らせというのが掲載され、データシートが訂正されました。

訂正対象>
Cisco 841M J シリーズデータシート
https://www.cisco.com/web/JP/smb/c800m/docs/c800mj_data_sheet_c78-732678.pdf
http://www.cisco.com/web/JP/product/hs/routers/c800isr/prodlit/data_sheet_c78-732678.html
https://www.cisco.com/web/JP/product/hs/routers/c800isr/prodlit/pdf/data_sheet_c78-732678.pdf

<訂正内容>
表 3. Cisco 800M シリーズ ISR の Cisco IOS ソフトウェア ハイレベル フィーチャ セット:
Advanced Security において、OSPFv3 が記載されておりましたが、同プロトコルは 
Advanced Security モデルである C841M-4X-JSEC/K9ではサポートされていないため、
訂正いたしました。

とりあえず、Cisco 841Mシリーズには、フューチャーセットのアップグレードパスが存在せず、買い換えしかないようで、販売店経由でといわれたものの対応しねぇ、と一点張りということなのでそのときのメールを送るなどして直接Cisco社に対応していただきました。ほんと、疲れた...
本当に商品担当の人に助けてもらわなければ解決出来なかったかと思うとぞっとします。ありがとう!

結局、昨年10月頃販売されて、おそらくそこそこの台数がでてるとおもうのだが、こういう質問がでてこないということは、誰もOSPFv3は使ってないのか?っおもう。そもそも論として、なぜ、IPv4では、OSPFもBGPも対応しているのに、IPv6だけ対応しないのか、これからIPv6が必須という時になぜはずすのかが理解出来なかったのです。そして、それにだれも気づかなかったということは、日本ではそれ以上にIPv6に対して遅れているということがいえるのではないかという感じ。あ、ちなみになぜ日本とくくっているかというと、Advanced Securityは日本限定販売のモデルだからです。日本の実情にあわせてるといっても過言ではないでしょうね。


 まとめ:

ということで、以前NetOneからCisco Start のWLC一式を購入したが、こちらは適切に保守登録がされており、ケースオープン、TACが問題なくきれるようですが、C841Mはケースオープン出来ないので電話で(ry だそうです。。。

おさっち  『こりゃ、中小企業向きでは売れませんね。』
[ コメントを読む(1) | コメントする ]

[Security][Windows] 標的型攻撃でねらわれるお馬鹿さんは、拡張子が読めないから?

Windowsのデフォルトでは、拡張子を表示しないため、zipなのか、バイナリなのか、ぱっと見てわからない。しかも、アイコン表示にしておくと、ファイル種別が表示されないので、判断が困難だ。まあ、強いていうならアイコンを見て判断するぐらいか。
なんで、拡張子表示させないの? exe とか zip とあるだけで、ひとまず警戒しろって出来るよね。 意味わからない。だから、そこをついて、〜.docx.exe とかはやるわけだよね。
Micro$oftがこのあたりの仕様を改善するだけ、拡張子を意識させるだけでずいぶん減るのではないか。もちろん、メーラーなどのアプリケーションももちろんのこと、拡張子がはっきり確認出来るようにしておくだけでもずいぶん減らせると思うんだが。昔も今も拡張子がみえないと意味わからない私がいる。

通りすがりこダメ人間  『docでもマクロウィルスなどあるので安心できません&拡張子偽装とか逆から綴るやつとかあるので、うっかりしそうな人は上司が滝行に出してやるべき』
tomocha  『確かにそうですね。ただ、マクロが含まれていると、最近のオフィスはマクロがあるので、実行を許可するか求めてくるとおもいますが、出てきたら、問題ないものか確認しましょうというフローでも大丈夫かと。 正しくない拡張子をつけて。。。だと、確かに気づけませんね。でも、戻さないと正しくアクセス出来ないので、その時点であれ?と気づくのかな。 まずは、拡張子、ファイル名を意識するところからしっかりと始めると、大半は防げるのかもしれません。ただ、本気でねらわれて、正規のメールを偽装(fromや名前などすべて正しく記載されているケース)はこの方法では防げませんが。 』
とおりすがり。  『拡張子出しておくと,名前の変更で消してしまう人が続出。 壊れました!と何度呼ばれた事やら。 ちゃんと大学は居る前に学校でで教育しなさいよ。と言いたいのだが・・・ 演習授業をしていると,最近の学生は全画面でアプリケーションを立ち上げて,マルチウィンドゥが使えない状況が多発。WordとExcelを同時に開いておけない。 拡張子など先の先の先・・・ 』
おとりすがり  『hoge.pdf .exe スペース入れまくって拡張子を表示外に飛ばす ってのもあるからファイル種別もよく見ろよ!! っていう社内釣りに釣られたことを思い出しました。』
[ コメントを読む(4) | コメントする ]

[Security][Network][Neta] Panasonic Switch-M16eG を購入・不良・交換したら YAMAHA RTX1200になり、納品物には設定済み。そのままフレッツにつないだら繋がるかもしれないが、不正アクセスになる?

福岡デイリーサービスという会社から、YAMAHA RTX1100および、 Panasonic Switch-M16eGというスイッチが安く出ていたので、全台(7台)を購入した。

このシリーズで有名なのは、PoEスイッチとして、Panasonic製の監視カメラの組み合わせて使うケースが多いと思う。もちろん、そのほかのメーカーであれば、Apresiaなども有名。

でも、今回購入したのは、非PoEモデル。 何がよいかというと、高温でも使える、FANレス、省エネモードがついてるインテリジェントであり、LinkAggregation、VLAN、SNMP対応、ミラーポートなど、最低限の機能などもつかえる。SFPポートも搭載している、高負荷をかけた状態でも15W程度ということだ。無負荷であれば、ワットチェッカーではかったところ、5Wを切り、測定不能というレベル。まとめると下記のような感じ。

島ハブとしてはとてもよいソリューションだ。RTX1100は1500円で出てたということ、まとめて買うなら送料が。ということで、現在動いているRTX1000が壊れたときのコールドスタンバイ。

現在はこんな感じで、今のところ壊れる様子もないが、いつ壊れてもおかしくない。

GW-RTX:> show environment
RTX1000
  main:  RTX1000 ver=XX serial=XXXXXXX MAC-Address=00:a0:de:XX:XX:XX MAC-Address=00:a0:de:XX:XX:XX
         MAC-Address=00:a0:de:XX:XX:XX
CPU:   5%(5sec)   8%(1min)   8%(5min)    Memory: 31% used
Firmware: internal  Config. file: 0
Boot time: 2009/12/31 03:07:21 +09:00
Current time: 2016/07/13 22:56:36 +09:00
Elapsed time from boot: 2386days 19:49:15

もう、2300日超えた。そろそろ6年ちょい。この機器を導入して、優に10数年。でも、いつお亡くなりになるかわかりません。

で、本題に入ろう、Panasonic Switch-M16eG を 合計7台購入して、うち2台、高周波音という異音を出す筐体が2台あったので、交換もしくは返品をお願いした。
しかし、交換品はない、返品も受け付けない、代替品で手を打たせてくれという。
で。代替品の提案がこういう内容。いや、調べろよ。

交換品のスペック等分りませんが...
NEC QX-S3126T-BS

交換品の提案が、 NEC QX-S3126T-BSで100M 24ポート、アップリンクにGigaポートがあるモデル。 全ポートGigaで省電力というものを購入しているのにもかかわらず、100Mのスイッチですよ。意味が全くない、てかゴミ。スペック知らずに適当に押しつけるのはどういうことかと。まずこの時点で対応がおかしい。
「要件(orスペック)があわないかもしれませんがいいですか?」
と聞くのが筋。
全ポートギガで省電力のインテリジェントでないと意味がないということで、突っ返したところ、「 代替品にYAMAHA RTX1200 2台でどうでしょうか。8ポートのSwitch-M8eGも2台つけます。」 ということだったので、手を打った。これは、ルータであり、HUBではないが、本当はRTX1100ではなく、1200がほしかったので了承。 8ポートのものもついたということで、合計16ポートになった。ラッキー。

届いたルータを確認していると、ログインできない。あら、気を利かせてくれて、設定をいれておいてくれたのか。ふむふむ。 パスワードなどの諸情報を教えてもらってないので、とりあえず時間も無いし、パスワードリカバリしよう。

YAMAHA ルータの場合、シリアルコンソール経由で操作するばあい、デフォルトパスワードとして、「w,lXlma」を入力すると、管理パスワードが不明でも管理モードになれる(詳細: 4.10 セキュリティクラスの設定)。ふむふむ、ログイン成功。てことで、こんな感じ。

ほ、ほう、親切に、VPNの設定とISPの設定をしてくれているじゃないですか。
事前に配線する前に、コンソールでつないで設定を確認したけど、このままフレッツにつなぐとPPPoEでASAHINETにつながっちゃうのかなぁ。
これ、 納品されたものに初期設定しておいてくれたものなので、使ってよいってことなのかなぁ。よくわからない。
これが、 不正に渡った、もしくは設定されていたアカウントなら、購入・納品されたルータをフレッツおよびLANに配線、設定しようとしたら繋がっていたというだけで、不正アクセス禁止法に引っかかるのかしら。 私は専門家でもなんでもない一般人なので良くわかりませんが。もし、ひっかかったら誰が罰せられるのだろうか。いや、ルーター安く買えた、とりあえずつないだらネットにつながった〜。っていうのは十分に考えられるシナリオ。

とりあえず、DDNSで osakanameosaka.aa0.netvolante.jp という名前が登録されていたので、調べてみよう。さらに接続先のホストに対して、osakanametokyo.aa0.netvolante.jp というのもあった。

$ host osakanameosaka.aa0.netvolante.jp
osakanameosaka.aa0.netvolante.jp has address 110.4.151.77

$ host osakanametokyo.aa0.netvolante.jp
osakanametokyo.aa0.netvolante.jp has address 14.3.35.187

$ ping 110.4.151.77
PING 110.4.151.77 (110.4.151.77) 56(84) bytes of data.
64 bytes from 110.4.151.77: icmp_req=1 ttl=241 time=32.8 ms
64 bytes from 110.4.151.77: icmp_req=2 ttl=241 time=27.3 ms
^C
--- 110.4.151.77 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms

$ ping 14.3.35.187
PING 14.3.35.187 (14.3.35.187) 56(84) bytes of data.
64 bytes from 14.3.35.187: icmp_req=1 ttl=242 time=24.0 ms
64 bytes from 14.3.35.187: icmp_req=2 ttl=242 time=19.9 ms
64 bytes from 14.3.35.187: icmp_req=3 ttl=241 time=20.0 ms
^C
--- 14.3.35.187 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 19.985/21.381/24.063/1.896 ms

ほ、ほう、生きてるのね。

ついでにこういうものもある。昔、2010年頃、YAMAHAがDDNSの移設をしたときか、ウォッチしていてミラーしたもの。

うん、2012/11/3の段階ではなかったレコードのようだ。
ということで、configを眺めてみると、VPNが3拠点はっているようで、descriptionからみると、大阪、福岡、東京の3拠点だった。

次に2台目を調査してみたところ、下記のような設定が入っていた。


(スクリーンショットをとるときに間違えてjpgにしてしまったらしく画質が...)

設定を確認すると、alpha-web.ne.jp って大塚商会。今はヴェクタント(現アルテリアネットワーク)のローミング。
最近、アルテリアのフレッツは品質落ちてますねぇ。。ココ。

脱線しちゃうけど、我が家の環境はISPはちがえど、アルテリアのローミング回線。RTTはこんな感じ。平日日勤時間帯のみRTTが40msぐらいまでのびる。この現象はここのところ最近のsmokepingの結果。ちなみに内部からではなく外部の契約しているDC上にあるネットワークからからsmokepingを仕掛けている。


参考に終端されているNTE側

明らかに法人ユースで平日日中帯だけRTTがのびる。
フレッツ側の終端はほとんど揺らがないが、アクセス側だけ揺らいでいる。

話を戻して、configんでいくと、記述方法が違うこと(特にフィルタ周りとかの定義の仕方)、互いに繋がっていないこと、ISPもIPアドレスも違うということもあり、この納品された2台は組が違うようだ。てことは、拠点の一部のルータが流れてきたってことか。

さらに調べていると、大塚商会にVPNソリューションというのがあり、 大塚商会 YAMAHA VPNルーターというのがある。ここのサイトによると、「大塚商会は導入から運用管理までワンストップで対応します。」と記載。これだったらおもしろいな。

いろいろとconfigをみたり、分析したりすると、おもしろいなぁ。それとも、わざわざRTX1200を設定済みのものを渡したって事は、引きこもりの末端作業員にVPNで接続してなにか仕事しろってことなのだろうか。うん、おもしろい 福岡デイリーサービスという会社であった。

まあ、どういう経緯で渡されたか不明だけど、設定済みのルータを配るときは危険なので、注意しましょう。てか、設定消せよ。まあ、configで、みられたらまずいものは、 4.10 セキュリティクラスの設定に記載があるとおり、forget off にしておくべき事案ですね。
ということで、中古で買うときは通電のみとかジャンクを買うとおもしろいですよ。てか、古物商やるなら、責任を持つというのを免許の項目に入れるべきではないか。情報漏洩する元は、販売する会社に問題があるということですね。

あと、福岡デイリーサービスという会社名を検索すると、よろしい評判はあまり見あたらないが、まあおいておくとして、 PC Watch: RITEA、中古情報機器取扱認定25社を発表という記事があり、調べていると、下記のような記載 が。

 PC等の普及に伴い、中古品の売買が増加したことで、HDD内のデータ未消去による情報漏洩問題が顕在化してきた。また、売買における基準や目安といった客観的な情報がないといった課題もある。

 これらの問題の解決のためRITEAでは、PC/サーバー/ワークステーションを対象に、良質な中古情報機器を取り扱う企業としての基本的な仕組み、中古情報機器の取扱に関する適切な業務処理の仕組み、ユーザーに対する適切な情報提供の仕組みからなる33項目の審査規定を設け、事業者に対して、買取(引取)、再生工事(データ消去)、販売、の3分野での資格認定を開始した。

もちろん、 一般社団法人 情報機器リユース・リサイクル協会 会員会社一覧にも記載があった。すなわち、正しく実施出来ていないもしくは、意図的に入れたまま出荷したというどちらかってことでしょうか。ま、後者だと思いますけどね(^^)

最後に)
私は設定済みのものをわざわざ納品してくれたという認識でかつ、購入したものを公開してはいけないというNDAなどは一切結んでいないので赤裸々に書いています。あくまでも商品を購入した側。またルーターメーカーの逆アセンブルを禁止するなどといったものにもふれておりません。センシティブなパスワードおよびシリアルナンバー、MacAddressなどは念のため伏せています。あくまでも購入したものをレビューしたにすぎませんので。
# IPアドレスから社名などわからないのでそのまま書いているし、書かないと他のストーリーが書けないから。


 別件で同じ業者から購入していたRTX1500は (8/13追記):



お見事っ!株式会社長崎ケーブルメディアのネットワークでがっつり使われていたようだ。
このアドレスの採番の仕方といえば、NCMから流れたものもしくはNCMと契約した顧客もしくはSIerから流れたものであるのはほぼ間違いないだろう。ちなみに、 法人向けIP-VPNサービスというのがあるが、こちらはMPLSやVLANをつかったとあるので、おそらくコレとは異なる可能性も。以前はどうかはわかりませんが。

おさっち  『Web Assistance でググると何台か出てきますよ。 レポート作成ボタンをクリックされれば、漏れ漏れですが。』
[ コメントを読む(1) | コメントする ]

2016年07月10日() [晴れ]

[Life][Internet] ルータリプレース、インターネットに繋がった♪

生活環境、テスト的にAristaのvEOSをいれてたけど、全く使い物にならないので、リプレースしたら、超快適になった。FreeBSD 10 + Quaggaも不安定だったので、Linuxに.... 安定性思考のFreeBSDはいずこ。てことで、安定しました。快適♪

ぃぇぃ

[ コメントを読む(0) | コメントする ]

2016年07月07日(木) [晴れ]

[DC] 日本ラッド目黒データセンターの取り壊しは平成28年7月19日から、事業主は伊藤忠商事株式会社でマンションが建つ予定らしい

(変更)「固定資産の譲渡及び特別利益の計上に関するお知らせ」の一部変更について
1. 変更内容・理由
本件の物件引渡期日及び物件代金入金日に関して、本日、引き渡しに必要な条件が全て確定したため、
平成28 年6 月30 日付で引き渡しを実行することになりましたので、お知らせいたします。

このIRをみて、6月末に引き渡しが完了したということで、解体工事がはいると、どこの会社が解体発注者かわかるため、現地に行ってみました。そしたら、見事に掲示されていました。

要約すると、次の通り

工事名称: (仮称)目黒区原町1丁目計画解体工事
場 所:   東京都目黒区原町1-22-3
工 期:   平成28年7月19日〜平成28年12月30日まで
事業主:   東京都港区北青山2-5-1
           伊藤忠商事株式会社
工事業者: 東京都港区芝浦3-17-11 ニュー協栄ビル
           株式会社合田工務店 (03-3454-6561)

掲示資料をみると、解体に当たり調査完了は平成28年3月24日 とのことなので、伊藤忠は3月の時点で解体に当たり建物の調査を実施していたとかんがえられます。

奥には、工事中の用に見えますね。

[ コメントを読む(0) | コメントする ]

2016年06月26日() [晴れ]

[Internet][NTT] 自宅のBフレッツファミ100は...

複数のセッションでも同様になっており、明らかにNTT側の問題と判断。
NTT東日本管轄からは、フリーダイヤルなど使えない。いろいろと困ったが、なんとか西ではないところから電話をかける方法を探し、電話したところ、NTT設備側では問題でていないということだったので、オンサイトによるONU、局からのレベル調査となった。

結局ONU交換で終わり。あーあ、長かった。てことで、この件があって、smokepingを仕掛けてみました。これ、ひどいよね。しかも発生するのは深夜帯のみ。意味不明。
交換後、この問題は出なくなったようだ。

[ コメントを読む(0) | コメントする ]

2016年06月16日(木) [晴れ]

[SPAM] 標的型攻撃メール

ここのところ最近ものすごく標的型攻撃メールが届く届く。
ほんと、糞食らえ。
ヘッダもよくいじられているし、それらしく見えるようになってる。
んで、最後に踏まれたホストは、k-opti のようだ

From ghostwrotepq2@ab.auone-net.jp Wed Jun 15 18:07:49 2016
Return-Path: <ghostwrotepq2@ab.auone-net.jp>
X-Original-To: tomo@XXXXXXXXXX.jp
Delivered-To: tomo@XXXXXXXXXX.jp
Received: from mx0.XXXXXXXXXX.jp (ns0.XXXXXXXXXX.jp [182.48.XX.XX])
        by mail.XXXXXXXXXX.jp (Postfix) with ESMTP id B85845C81F
        for <tomo@XXXXXXXXXX.jp>; Wed, 15 Jun 2016 18:07:49 +0900 (JST)
Received: by mx0.XXXXXXXXXX.jp (Postfix, from userid 65534)
        id B277E50EC1; Wed, 15 Jun 2016 18:07:49 +0900 (JST)
Received: from [218.228.253.122] (unknown [218.228.253.122])
        by mx0.XXXXXXXXXX.jp (Postfix) with ESMTP id DDC7450E67;
        Wed, 15 Jun 2016 18:06:46 +0900 (JST)
Received: from [56.102.176.82] (helo=knkta.fiaxfeeopv.info)
        by  with ESMTPA
        (envelope-from <noreply@mm.post.japanpost.jp>)
        id F449497F4AC3
        for tomo@XXXXXXXXXX.jp; Wed, 15 Jun 2016 17:45:37 +0900
Received: from [156.113.193.181] (helo=wquh.nuz.ab.auone-net.jp)
        by  with ESMTPA
        id 60BC9DF6F8
        for tomo@XXXXXXXXXX.jp; Wed, 15 Jun 2016 17:45:37 +0900
MIME-Version: 1.0
From: <noreply@mm.post.japanpost.jp>
Reply-To: <noreply@mm.post.japanpost.jp>
X-Mailer: Zimbra 8.6.0_GA_1162 (ZimbraWebClient - FF44 (Linux)/8.6.0_GA_1100)
Date: Wed, 15 Jun 2016 17:45:37 +0900
To: <<tomo@XXXXXXXXXX.jp>,
        <tomo-mldd@XXXXXXXXXX.jp>>
Subject: =?iso-2022-jp?B?WxskQkZ8S1xNOUpYGyhCXSAbJEI9ODJZME1Naj89OX4kXzQwTjskTiQqQ04kaSQ7GyhC?=
Content-Type: multipart/mixed; boundary="----=qV-jdPZzUfxmHlRT_PRv3Wga"
Message-ID: <da444e16ec50b2984946@xlzct.zrgohyhac.ab.auone-net.jp>
X-URIRBL: No, test=check_uri.pl, version=1.50

------=qV-jdPZzUfxmHlRT_PRv3Wga
Content-Type: text/plain; charset="iso-2022-jp"
Content-Transfer-Encoding: 7bit

受付番号:S16059317887588

この度は日本郵便のWeb集荷サービスをご利用頂きありがとうございます。
上記の受付番号は、お問い合わせ・内容修正・申込取消の際に必要となります。
このメールを保存または印刷していただくよう、よろしくお願いします。
お申込み内容は以下のとおりです。
----------------------------------------------------------------
電話番号:0157-52-2311 内線:

集荷希望時間帯:15:00‐17:00

商品:ゆうパック
個数:1個
送り状の用意:用意済み

----------------------------------------------------------------
なお、このメールアドレスは送信専用となっております。
本メールに返信されましても、ご質問等にお答えすることは出来かねますのでご了承ください。
〒------------------------------------------〒
日本郵便株式会社
〒100-8798 東京都千代田区霞ヶ関一丁目3‐2

 ゆうびんホームページ
 http://www.post.japanpost.jp/
〒------------------------------------------〒

------=qV-jdPZzUfxmHlRT_PRv3Wga
Content-Type: application/zip; name="POST.44369462486191360932 PDF.zip"
Content-Transfer-Encoding: base64
Content-ID: <000601d1c72d$b9af3c60$c70210ac@FMB491QC>

そのほか、こんなやつも。

阪本様

お世話になっております。
月額管理費ですが、月額507,000円で認識はあっていますでしょうか。
宜しくお願いします。
[ コメントを読む(0) | コメントする ]

2016年06月01日(水) [晴れ]

[Neta] 自称プロ写真家(キャンディ @SK_rainie)に写真をパクられた事について書いてみた

事の発端は、東京の中央線に位置する西荻窪駅でのグモ発生の時の写真。

私は、スマホの写真の画質が悪く使えたモノじゃないので、同レベル程度に扱える所詮コンデジカメラを常時持ち歩いている。そのためか、ポケットにいつも SONY α6000が入っており、スマホ並の機動力で写真を撮ってる。

そんな中、病院の帰り、西荻窪駅で人身事故勃発。
ちょうどよかったので、新聞社にでもネタを売りつけれるかな?と思い、結構な枚数の写真をカシャカシャと撮影していた。
その一部の写真をTwitterに書いていたら、自称プロ写真家にパクかれたという話。

まずは、つぶやいた写真はこちら。

投稿した時間は、22:51 こちらがオリジナル。
パクられた投稿は、23:13と23:19の発言



この @SK_rainie という人がどういう人か見たところ、下記のようなプロフが掲載されていた。

緑の人、カメラマンしてます。photographer 依頼はメール、リプにてお受けします。主に、ポートレートなど、完全受注生産にて写真集を作ります。

そうか、自称プロカメラマン、フォトグラファーか。立場を理解をしたうえで、この写真を自分の写真のように偽って投稿したわけか。なるほど。

というわけで、反撃開始。

楽しい事件が発生しました。はい、炎上させます、便乗したい人はどうぞ
@Sk_rainie という「カメラマンしてます。」という本職?の人が私の写真をパクリました

そうすると、あわてて投稿を消しました。「ごめんなさい」と一言、言えば音便にすますつもりでしたが、一向になく。
自称本職の人が使うということですので、写真利用料でもということで、「お買い上げありがとうございます。」と 投稿したところ、ブロックしてきました。

ま、完全に逃げ切りですね。逃がしません。

ちょこっと、調べてみたら、緑の人と書いてあります。

ひょっとして、Ingressかな?と思い、調べてみるとこういうのが。

ほお、Ingressやっていて、IRTにきますか。なるほど。埼玉県南部、武蔵浦和ですか。
このメッセージは、2015/06/23ですね、Resistanceにきてるってことは、当時は青ですか?
とりあえず、@Skrainie をぐぐたすで調べてみますか。とおもったら、日記を書いている時点では、IRTのグループにはいないようでした。

ということで、 Google+を見つけたのですが、Ingress Registance Japan および Ingress Enlightened Japan 両方にかき込みしているなど、ちょっといろいろとアレな感じがしました。
記念に スクショ。

ちなみに魚拓でページを押さえましたが、削除申請を出したのか削除されておりました。不適切なユーザーとして、Twitterに報告を出しましたがアカウントはまだ生きているようで。

[ コメントを読む(0) | コメントする ]

Diary for 15 day(s)
Powered by hns-2.19.6, HyperNikkiSystem Project




(c) Copyright 1998-2014 tomocha. All rights reserved.