title
TOP / Wiki / Diary / Profile / PC / BBS / Mail
わたしの日記は日々の出来事の鬱憤晴らしの毒だし日記がメインです。 相当病んでいます。くだを巻いています。許容出来る方のみのアクセスをお願いします。 また、この日記へのリンクは原則自由にして頂いても結構ですが、 写真への直リンクを張るのはご遠慮下さい。内容に関しては、一切保証致しません。
カテゴリ一覧 Network, Internet, IPv6, DC, NTT, Comp, Linux, Debian, FreeBSD, Windows, Server, Security, IRC, 大学, Neta, spam, , 生活, 遊び, Drive, TV, 仕事,
過去日記:



2016年07月22日(金) [雨]

[Computer] archive.org 月刊 I/O アイ・オー

超なつかしすぎる。私が生まれてない時代のもあるけど。

[ コメントを読む(0) | コメントする ]

[Network][Life][Other] Pokemon Go を使いたければ、NAT環境はすべて規約違反になるのか?

本日めでたく、Pokemon Goが配信されました。早々にインストールして気になっていた規約を読むと...

一言で要約すると、Pokemon Go の利用規約の禁止事項には、「TCP/IP ... ヘッダ情報の一部を偽造し、又は、何らかの方法で本サービス ... 改変・偽造された、又は不正なソース特定情報」とあるので、NAT/CGNはアドレス、ポート変換がされるので、改変(not偽造)に当たるぞ。3大キャリアや、ブロードバンドルータ、モバイルルータでは規約、しかも禁止事項に抵触するぞ!使っちゃだめだぞ!(かなり強引)

じゃあ、どうやってプレイするんだよ、それは、グローバルIPを付与するキャリア以外のMVNO SIMを契約しろよ!ってことだろうね(かなり強引)。

これで、MVMOブームがやってくるっ!(きっと...)

ということで、解説。

もともと 利用規約を読んだ理由は、ingressと同時プレイはアウトかどうかが気になっただけなのですが、それよりも気になったのは下記の通り。

TCP/IPパケットヘッダ若しくはメールやニュースグループのヘッダ情報の一部を偽造し、又は、何らかの方法で本サービス若しくはコンテンツを利用して改変・偽造された、又は不正なソース特定情報を送信すること。

「TCP/IP ... ヘッダ情報の一部を偽造し、又は、何らかの方法で本サービス ... 改変・偽造された、又は不正なソース特定情報」とあり、 NAT(Network Address Translation/ネットワークアドレス変換)を使用した場合、IPパケットのヘッダの書き換えを行っている。一般にCGNやブロードバンドルータが実装しているのは、NAPT(Network Address Port Translation)であり、 IPアドレス変換だけではなく、ポート変換も行っているすなわちパケットのヘッダの書き換え、すなわち改変を行っている技術である(強引すぎ?)。

よって、ポケモンGoをつかいたければ、キャリアSIMは規約違反になるし、多くのホットスポットで使うこと、モバイルルータ経由でつなぐのも規約違反、禁止事項に該当するのではないかと考えられる。

ただし、ソフトバンク系が提供している一部のmobilepointおよびそのローミングは、IPv4のグローバルIPを付与しているので、NATは使われていないと思うので、問題ないだろう。間に何が入ってるか不明だが...

次に、トンネリング技術やVPN技術を使用した場合、「又は不正なソース特定情報を送信」というのが、引っかかるのではないか。なぜならば、ソース特定情報とは、明確に誰もがわかるように書いていないが、 GeoIP(IP Geolocation)のことではないかな、と思います。すなわち、IPアドレスによる位置情報を検索しているので、VPNやトンネリングを使うと、単一のIPアドレスをどこでも使えるようになりますが、これも禁止しているとなると、フレッツなどのPPPoEもアウトではないかと。

すなわち、許されるのは、トンネリングやpppを使わない、IPアドレスでないといけないとなると、専用線やEthernet接続がされているものでなければならないと仮定すると、モバイル端末はすべてアウトなのではないかと。その回線上でつながった、Wi-Fiでしかプレイできないということになる。(結構強引?)

ソースという意味で、ソースアドレスの書き換えという読み取り方をすると、NATとも読み取れる。

ま、後者については、かなり強引な解釈なので、こちらは無視するとしても、前者はアウトのように見えることから、NATを使う環境ではプレイできない。

グローバルIPを付与するSIMといえば、biglobeや、そのほかでは、固定IPを提供するISPなどしかわからない。

最近、三大キャリアである、ソフトバンクモバイル(含旧イーモバイル)、AU、ドコモ共にLSN(CGN)配下でプライベートIPである。IIJmioもNAT配下。

てことで、そもそもこの禁止事項が現代の状況にあってないので、明らかにおかしいよね。だって、ニュースグループって・・・。Pokemon Goってニュースグループって使ってるんですかね? あと、IPv4アドレスが枯渇といってるこの時代。

[ コメントを読む(0) | コメントする ]

2016年07月17日() [晴れ]

[IPv6][NTT][Internet][Network] IPoE + IIJmio + Transix + DS-Lite で実験

背景として、広域(東阪/奈)でネットワークが敷設してあり、Cisco WLCを導入し、Flex Connectで繋がっている。
Flex Connectを敷設してある拠点ではどこででも同じVLANにアクセス出来る構成となっている。

ちょっと早いが母の日にということで、iPad2をプレゼントしたので、それようのゲストWiFiを用意する必要が出来た。

ただ、既存のv4環境はVPNやDCなどと繋がっていたり、特定のサイトにアクセスが可能なネットワークとなっているため、そのまま出せない。 ip filterをすべてのサイトに対して実施するのは事実上困難であり、別の回線を用意するか、あいているグローバルIPでNATをして専用のネットワークを出すか、もしくは別途ISPを契約するしかなかった。また、友達が遊びに来た際、提供出来るネットワークも作りたかったので、環境を準備することにした。そのほかテスト用の端末や、大容量のサイズをダウンロードするときも高速なネットワークがほしいと思ったりもする。

そこで、既存の環境はそのままで、新たに Transix + DS-Lite の設定を用意すれば、別途ISPの契約もグローバルIPの消費もいらないという名案が浮かび上がり実装することにした。

ちなみに西の回線はBフレッツファミリー100なので、IPoEではないので、この方法は使えないので、東の環境で構築し、VLANをのばしたり、Flets Connectを使ったりして、西の方で提供、母親が使えるようにした。
環境は以下の通り。

Ciscoの設定は簡単で、下記のようにすればよい。このあたりは インターネットマルチフィード DS-Lite IPv4接続オプション接続確認機種情報Cisco 1812Jを参考にすればよい。

我が家では下記の通り設定した。
なお、2404:8E00::FEED:100 および 2404:8E00::FEED:101 はAFTRのアドレスだ。

 ! ONU
 ! track 100 interface GigabitEthernet0/5 line-protocol

 ! DS-LITE
 interface Tunnel1
  description MF-DS-LITE
  ip vrf forwarding guestnet
  ip address 192.0.0.2 255.255.255.252
  ip nat outside
  ip nat enable
  ip virtual-reassembly in
  tunnel source GigabitEthernet0/5
  tunnel mode ipv6
  tunnel destination 2404:8E00::FEED:100

 ! LAN IF
 interface Vlan100
  description TOKYO-GUESTNET
  ip vrf forwarding guestnet
  ip address 172.16.0.3 255.255.252.0
  ip nat inside
  ip virtual-reassembly in
  ip ospf shutdown
  ospfv3 shutdown
 ! vrrp 100 ip 172.16.0.1
 ! vrrp 100 timers learn
 ! vrrp 100 priority 90
 ! vrrp 100 track 100 decrement 254
 ip route vrf guestnet 0.0.0.0 0.0.0.0 192.0.0.1

これで、パフォーマンステストで1Gbpsぐらいの負荷をかけようとしたり、TCPセッションが何本はれるか実験をした。
そうすると、40Mbps程度しかでなく、おっせーなー、とおもいPPPoEの方が、200Mbpsぐらいでて早いじゃん・・・という無残な結果。

IIJのてくログには、 IIJmioひかりの混雑の理由とバイパス手段(IPoE・DS-Lite対応)にかいてある通り、DS-Liteのほうが早いという期待をしていたが、かなりガックシ。おっせーとおもい調べていたら、ルータのCPUが100%になっていることが判明し、このルータではないな、、、という無惨な結果。この結論はおいておいて、おもしろい遊びが出来るおもちゃを手に入れてしまったので、遊んで^H^H^H検証してみることにした。

sample configはこんな感じ。

interface Tunnel0
 description MF-DS-LITE
 ip address 192.0.0.2 255.255.255.252
 ip nat outside
 ip nat enable
 ip virtual-reassembly in
 tunnel source GigabitEthernet0/5
 tunnel mode ipv6
 tunnel destination 2404:8E00::FEED:101

interface Tunnel1
 description MF-DS-LITE
 ip vrf forwarding guestnet
 ip address 192.0.0.2 255.255.255.252
 ip nat outside
 ip nat enable
 ip virtual-reassembly in
 tunnel source GigabitEthernet0/5
 tunnel mode ipv6
 tunnel destination 2404:8E00::FEED:101

IPv6はvrfを切らず、ipv4だけ vrf をきった。
その上で、DS-Liteのtunnelを2つ作成、検証。

検証1: 何セッション使えるか(NATセッション数)

サーバー側にダミーのポートを準備、接続出来る状態にする。CE配下の各vrf毎に同一のサーバーにncでソケットオープンし、何個開けるか実験、サーバー側でnetstatの数を集計

結果:BR側の出口のv4アドレスはどちらも同じ、合計 1012 しか使えなかった。
ちなみに、AFTRは同じにしているが、別のケースは検証してない(いや、しろよ・・・ていうか、するべきだなぁ)

検証2: vmware上に構築したvyosでパフォーマンスおよびセッション数の検証および検証1環境と同時に使用
検証1では無惨な結果だったので、vmware上にvyosをあんちょこで展開し環境構築。でDS-LiteのCEを実装、5分ぐらいで出来た。
configは下記のような感じ。

set interfaces ethernet eth1 address '172.16.0.2/22'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 hw-id '00:0c:29:8d:07:92'
set interfaces ethernet eth1 smp_affinity 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces tunnel tun0 address '192.0.0.2/30'
set interfaces tunnel tun0 encapsulation 'ipip6'
set interfaces tunnel tun0 local-ip '2409:10:xx:xx::xx:xx:xx'
set interfaces tunnel tun0 multicast 'disable'
set interfaces tunnel tun0 remote-ip '2404:8e00::feed:100'
set protocols static interface-route 0.0.0.0/0 next-hop-interface 'tun0'

結果: 600Mbpsぐらいでた出る。
この状況で、Ciscoルータをゲートウェイに向けた端末と、vyosをゲートウェイに向けた端末を比べてみると、出口のv4アドレスが違うことが判明。セッションもおのおので独立していることから、CE側のIPv6のアドレス毎に決まるようで、prefixの割り当て毎にポート数が割り当てられるのではないようだ。
また、一定の間隔でTCPセッションを張りっぱなしにしておくと、出口のv4は変わらないが、通信が無くなり、しばらくセッションがいなくなると、次の通信の段階で出口のv4アドレスが変わっていることが判明した。こうやってアドレスを共有し、切りつめているようだ。

すなわち、Ciscoの遅いルータで環境を構築するぐらいならば、DS-Liteを実装したvm箱をたくさん用意すれば、高速な箱が完成、セキュアに独立したインターネット出口を用意できる。これは、案件や用件、利用者毎に準備すれば、回線を複数引かなくてもよく、独立したおのおののネットワークが構築可能だ。

また、フレッツ IPv6オプションを契約すれば、NTT東西はまたげないものの閉域網内で折り返し通信が可能。この上でIPv6 VPNを張り、代表となる回線にTransixやJPNEなどのIPoEを開通、DS-LiteやMAP-Eなどで出て行けば、1Gほぼフルに使えるISPができあがり。セッション数が足りなければ、違うIPv6アドレスでCEをつくればいくらでもセッション数は増やせる。増やした場合、ロードバランスするVMもしくは、ソースアドレスルーティングをして、内部でルータ振り分けをするルータを作れば完成。これで高品質な広帯域のインターネット接続が確保出来るという寸法。

ちなみに、IPoEのIPv6アドレスの固定は保証されていないものの実質固定。その中でルート的なサーバーを何台かに分散して持たせておけば、DDNS的なことも出来るだろう。ISPの契約も1つで、後は回線だけでよい。こういうおもしろいことも出来るおもちゃ。
こういう高品質の上にストレージネットワークを作ってもいいね。低レイテンシーだそいろいろと遊べそうだ。とおもったら、登君が 「OPEN IPv6 ダイナミック DNS for フレッツ・光ネクスト」サービスを公開というのを作っていた。ちなみにこのネタで遊んで他のはプレスリリースを出す前だ。考えることは同じだなぁ。


 まとめ:

まとめると次のような感じ。

テストをして遊んだ後、vyosがmaster、cisco(guestnet用vrfを作成)がbackupとして冗長、メンテナンスや障害時も無停止でメンテナンス出来るようにした。パフォーマンスは落ちるけど...

[ コメントを読む(0) | コメントする ]

[Network] 841Mをつかってみて

使っている環境は、IPv4(PPPoE, OSPF, vrf, NAT), IPv6(PPPoE, OSPFv3, vrf) という構成。vrfは自宅内にゲスト環境と仕事用の環境、プライベート環境が混在しており、特定のVLANはデータセンターに繋がってるとか、ルーティングされているといったものがあり、分けないといけないことから、vrfが必須になっている。元々複数のルータを使ったり、ACLでがんばっていたもののそろそろきつくなり、vrfを採用した。

フレッツでPPPoEを使っていると、NATセッションを酷使していない範囲では、200Mbps程度問題なく出る(フレッツのv4の上限なので問題ない)ので、パフォーマンスには特に問題ないが、一定の周期でRTTが大きくなり、1ms〜10ms強のジッターが発生する。

--- 192.168.XX.XX ping statistics ---
169 packets transmitted, 169 received, 0% packet loss, time 168439ms
rtt min/avg/max/mdev = 0.592/1.030/14.076/1.371 ms

おおよそ、30秒〜50秒程度の間隔なので、OSPFの周期ではないかと想像しているのだが、このジッターが実は結構不快感を肌で感じることが出来てしまいきつい。

また、DS-Liteを使った場合、CPUが張り付いてしまい、実効スループットは、40Mbpsも出ない。

[ コメントを読む(0) | コメントする ]

[Network][IPv6] Cisco 841M 15.5(3)M でIPv6の通信が不安定、原因は、ipv6 cef という可能性が濃厚

Ciscoサポートコミュニティーにも投稿されているが、この問題はコミュニティー上では解決せず、「サービスリクエストをオープンいただいた方がよいと思います。」という状況になっている。
同様の問題も構築中に発生し、IPv6 PPPoE でDial、SVIを数個切ってる。
DHCPv6で取得したSVI配下の端末から、ping6を送信すると、きれいに50%(2個に1つ)かならずロスするという問題があった。
いろいろと調査していく結果、Ciscoルータからpingを送信したばあいロスしない、ルータがSVIをまたいでフォワードするケースでパケットが50%きれいに落ちるという状況。

実は、cefが問題ではないかとおもい、下記のコマンドを投げた。

# no ipv6 cef
# ipv6 cef

そうすると、見事に回復。Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング) にバグがあるのが明確となった。さて、どうしたものか....とりあえずの work around はあるものの気持ち悪い。さあ、IOSを提供してもらおうかとおもうと、また、電話で・・・かよ。。とおもうと気が滅入る。ちなみに、My Ciscoには未だに保守登録がされておらず、ケースオープンが出来ません。よって電話で(ry

[ コメントを読む(0) | コメントする ]

[Network] Cisco C841M-4X-JSEC/K9 を導入したらドはまった。だって、データシートに書いてあるOSPFv3が動かないんだもの。という顛末。

家のネットワークが、IX2015 で 100Mであったこともあり、そろそろGigaにしたいなぁと。ちょうど、ヤフオクで大黒屋というところが、新品で出品していたC841Mを落札。このCisco Startシリーズは、最初から保守が2年込みがウリ。15kぐらい。買う前に、IPv6に対応していること、OSPFv3およびVRFに対応していることが条件だった。
いろいろとやりとりをしているウチに、後述する理由でデータシートなどを書き換えられてしまったので、とりあえず、当時の公開されていたスペックは下記を参照にしていただきたい。

INTERNET Watch: 誰のための日本語GUIなのか? 中小企業向け低価格ルーター「Cisco 841M J」( データシートミラー, スクリーンショット)

データシートでは、OSPFv3が使えるとある。ただし、BGP4+にはPDFのデータシートには対応と記載があるが、Webには未記載。
後者は謎であったが、今回対外接続でBGP/BGP4+でフルルート食べさせたりしないので、Advanced Security で 必要要件には十分であった。

実際に導入するべく、環境構築、検証してみると、OSPFv3が動作しない。
まず、環境は下記の通り。

#sh ver

Cisco IOS Software, C800M Software (C800M-UNIVERSALK9-M), Version 15.5(3)M, RELEASE SOFTWARE (fc1)

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*1        C841M-4X-JSEC/K9      FGLXXXXXX

License Information for 'c800m'
    License Level: advsecurity   Type: Permanent
    Next reboot license Level: advsecurity

OSPFv3の設定をいれてみようとすると、下記のようなエラーメッセージ。

(config)#router ospfv3 1
Protocol not in this image

(config)#ipv6 router ?

rip IPv6 Routing Information Protocol (RIPv6)

(config)#


(config)#int vlan XX
(config-if)#ipv6 ospf ?
% Unrecognized command

Protocol not in this image といわれ、このイメージ(C800M-UNIVERSALK9-M)では使えないといわれるので、シスコサポートコミュニティーの Cisco Startルータというコミュニティーに C841M-4X-JSEC/K9 で、OSPFv3を使いたいと投稿した。

それと同時に、固有の問題と考え、改めて、Amazon で Cisco Systems ギガビット対応VPNルータ C841M-4X-JSEC/K9/START【保守2年付】というのがあり、ぽちっとなと購入して検証してみたが、同じ挙動。


 保守登録ができない:

仕方なく、サポートコミュニティーに投稿しても応答がなく、しかたなく、ケースオープンをするため、保守登録をしようとすると、販売店は登録しないという。大黒屋は新品ということで購入したが、保守登録のしかたもわからないし返品の対応もしない、メーカーに聞けと一点ばり。Ciscoは販売店にいって、登録してくれという。行き詰まる。で改めてCiscoの回答を販売店に伝えると、大黒屋は販売店に聞けと何度も言う。 もう一点で購入した SMART1-SHOPも同じことを言う。エビデンスとして次のようなメールをもらった。

大黒屋

質問)
----
Cisco製品の場合は、新品の場合は、基本的に保守加入が必須となっておりますが、
手続きについて教えてください。
こちらで登録しようとした際できなかったので販売店から登録してもらう必要があります。

ソフトウェアについて、最新のものを提供をお願いいたします。
確認したところ、現時点で、

 c800m-universalk9-mz.SPA.156-2.T.bin

が最新のものとなっています。

また、OSPFv3の使用を前提で購入していますが、下記の内容には対応とありますが、
今回納品いただいたものでは使えませんでした。
ご確認いただけますか?
必要に応じてTACにあげる必要があると思いますので、保守情報をいただけないのであれば、
そちらで対応願います。


回答)
----
保守加入の件ですが未使用品の為、確認はしておりませんでした。
申し訳ございません。
また専門店でない為、今回の件はお手数ですがメーカーに
お問い合わせください。
万が一問い合わせされても解決されない場合はこちらの連絡掲示板に
ご連絡ください。
ご対応させて頂きます。
宜しくお願い致します。

やりとりをして返品を要求したが結果、データシートに記載事項が動かないが電源が入るといったニュアンスで、拒否。途中で返事が無くなった。

SMART1-SHOP - Amazon マーケットプレイス <XXXXXX@marketplace.amazon.co.jp> 

ご連絡頂きました保守登録につきまして、誠に申し訳ございませんが、
お客様にてご登録を行なって頂いておりますので、何卒ご了承頂きますよう、
宜しくお願い申し上げます。

なお、ご登録方法につきましては、下記メーカーサポートにて
ご案内をさせて頂いておりますので、ご利用下さいませ。

【Cisco Systems】

TEL 0120-092-255

平日 10:00〜12:00、13:00〜17:00

以上、大変お手数ではございますが、ご確認頂きますよう、
宜しくお願い申し上げます。

 保守登録は出来ないもののケースオープンは出来た:

こういう糞会社は排除すべき。ということで、晒しあげる。らちがあかなくて何度もやりとりしてて、ルータに不具合があるのか動かないので、困ってるといったら、保守の登録はしてないものの有効期限を確認しますとのことで、期間内。そりゃ、販売されてそんなにたってないし、購入して数日ですから。とにかく症状を伝え、チケットを切ってもらった。内容は、OSPFv3が動かない。どうしたら動くか?という内容。

そこから、問題解決まで1ヶ月ほど。。。中国人の対応がものすごく悪く、クレームをいれもしたが、やりとりの最中、いきなりガチャ切りするわ、名前を間違えるはで最悪。聞いてみると大連に飛ばしているらしく中国人。チケットでのエビデンスものこさず、電話ばっかりかけてくる。いや、こっち、現場作業員のOLだし、その場で確認できるわけでもないのに、今すぐ確認しろとか平気でいってくる。その割には記録としてチケットに残さない状態。もう、サポート最悪。

結局、その後、サポートの方も困ったらしく、商品担当にエスカレしたようで、FacebookのDMでともちゃ、あれの件だけど・・・僕商品担当。。。ということで、裏でやりとりしつつ・・・。えっと、とてもコストの高い知人が出てきてしまって焦る。ま、無事に解決して、全台保守交換となった。


 RMAで交換品はDHLで...:

交換品を送るときに運送会社を聞いても、中華野郎はわからないと。確認しますといって、最終的に判明したのは、DHL、ここから地獄の始まり。
DHLは平日にしか配送出来ない(=土日祝は不可)、時間指定も出来ないという。

末端作業員のOLの身としては、平日は家にいないし、平日時間指定出来ないといわれると、そもそも受け取りできない。会社に送るにしても元箱含めてでかいしむりだし、そういう場所でもない。
そして、中華の人はなぜ受け取れないのか理解出来ないという状況。

あいつらは仕事さぼればいいとでもおもってるのか、と喉から台詞が出てきそうになってしまう。
が、ぐっとこらえて、DHLでおくられたら一生受け取れないよ。誰かに受け取ってもらえないのかともいわれるけど、無理。一人と返す。

一人暮らしの寂しい末路を送ってる婚期を逃した生き遅れの私にはとうてい無理ってこと。相方仮にいてても、仕事してるだろうにw

そして、振り出しに戻り、配送業者から不在ですと連絡が入ったようで、電話。

「いつ受け取れますか?」

と会話が成り立たない。


 とりあえず六本木経由で佐川で送ってもらった&RMAで返送するのもDHLとか...:

んで、困って、ひとまず、商品担当の人に相談。そうすると、結局、六本木で受け取ってもらい、佐川急便で発送してもらうということに。
佐川急便は車で往復50キロ弱ドライブしたら24時間受け取れる集荷場があるので、それで送ってもらった。
ちなみにクロネコヤマト宅急便やゆうパックなどは19時、17時なのです。通勤片道2時間以上かかってるような田舎ものには受け取れません。

この時点で、保守部品到着後の返却期限がきていて、不良品はいつ返送してくれますか?と中華の野郎は電話してくる。

さすが交換品を受け取ってないのにそれはねーだろ。とブチ切れ寸前。そして、返送方法を確認してみると...

要約すると、「DHLに集荷の依頼をして、送り返せ、平日しか無理だ。受付は24時間WEBでできるけどな、ガハハハ」

という感じで、平日家にいねーっていってるだろと。深夜0時以降きてくれるならええぞといったら、出来ませんって。。

最終的に、使える運送会社でいいから送り返してくれってことになった。


 佐川の対応が今回はいつも以上に糞。わかってたけど。:

佐川急便で不在伝票がはいってたので、 電話をしたら、営業所はでない、自動音声。仕方なく24時間の営業所まで片道25kほど車でドライブしていくと、
一言目に、 事前に連絡くれました?探すのに時間かかりますよ。

だと。何度電話しても出なかったのはどこのだれですか?出ないんだったら繋がる番号を教えろいうが、教えれない。と返された。
相当殺意がわく。

そして、伝票を渡して、引き取るとき、身分証明出来るものをいわれたので、伝票と免許証でセットであって名前も書いてあるが、本人確認できない、住所確認ができないといって引き渡し拒否しやがる。1時間ぐらいもめてやっと引き渡し。その間、トラックがやってきて、Amazonの物流用のトラックだったようで、暇なので受付けエリアから写真をとりまくって、中を観察してじろじろとみて、Twitterにあげるw ぐずぐずするからだよ。んたく。
ちなみに、本人確認できない、住所確認できないとかいわれたの初めてです。伝票、同じ名前の免許証で。だったら、今から帰るから、その住所に持ってこいといったら出来ませんとさ。ほんまに佐川も糞。

やっと受け取り、交換、再設定。これで、IP Advancedとなりました。
解決の後、クロネコヤマト宅急便で深夜にコンビニに車で持って行って返送しました。


 その後、データシートが修正される:

その後、 シスコサポートコミュニティ C841M データシート訂正のお知らせというのが掲載され、データシートが訂正されました。

訂正対象>
Cisco 841M J シリーズデータシート
https://www.cisco.com/web/JP/smb/c800m/docs/c800mj_data_sheet_c78-732678.pdf
http://www.cisco.com/web/JP/product/hs/routers/c800isr/prodlit/data_sheet_c78-732678.html
https://www.cisco.com/web/JP/product/hs/routers/c800isr/prodlit/pdf/data_sheet_c78-732678.pdf

<訂正内容>
表 3. Cisco 800M シリーズ ISR の Cisco IOS ソフトウェア ハイレベル フィーチャ セット:
Advanced Security において、OSPFv3 が記載されておりましたが、同プロトコルは 
Advanced Security モデルである C841M-4X-JSEC/K9ではサポートされていないため、
訂正いたしました。

とりあえず、Cisco 841Mシリーズには、フューチャーセットのアップグレードパスが存在せず、買い換えしかないようで、販売店経由でといわれたものの対応しねぇ、と一点張りということなのでそのときのメールを送るなどして直接Cisco社に対応していただきました。ほんと、疲れた...
本当に商品担当の人に助けてもらわなければ解決出来なかったかと思うとぞっとします。ありがとう!

結局、昨年10月頃販売されて、おそらくそこそこの台数がでてるとおもうのだが、こういう質問がでてこないということは、誰もOSPFv3は使ってないのか?っおもう。そもそも論として、なぜ、IPv4では、OSPFもBGPも対応しているのに、IPv6だけ対応しないのか、これからIPv6が必須という時になぜはずすのかが理解出来なかったのです。そして、それにだれも気づかなかったということは、日本ではそれ以上にIPv6に対して遅れているということがいえるのではないかという感じ。あ、ちなみになぜ日本とくくっているかというと、Advanced Securityは日本限定販売のモデルだからです。日本の実情にあわせてるといっても過言ではないでしょうね。


 まとめ:

ということで、以前NetOneからCisco Start のWLC一式を購入したが、こちらは適切に保守登録がされており、ケースオープン、TACが問題なくきれるようですが、C841Mはケースオープン出来ないので電話で(ry だそうです。。。

おさっち  『こりゃ、中小企業向きでは売れませんね。』
[ コメントを読む(1) | コメントする ]

[Security][Windows] 標的型攻撃でねらわれるお馬鹿さんは、拡張子が読めないから?

Windowsのデフォルトでは、拡張子を表示しないため、zipなのか、バイナリなのか、ぱっと見てわからない。しかも、アイコン表示にしておくと、ファイル種別が表示されないので、判断が困難だ。まあ、強いていうならアイコンを見て判断するぐらいか。
なんで、拡張子表示させないの? exe とか zip とあるだけで、ひとまず警戒しろって出来るよね。 意味わからない。だから、そこをついて、〜.docx.exe とかはやるわけだよね。
Micro$oftがこのあたりの仕様を改善するだけ、拡張子を意識させるだけでずいぶん減るのではないか。もちろん、メーラーなどのアプリケーションももちろんのこと、拡張子がはっきり確認出来るようにしておくだけでもずいぶん減らせると思うんだが。昔も今も拡張子がみえないと意味わからない私がいる。

通りすがりこダメ人間  『docでもマクロウィルスなどあるので安心できません&拡張子偽装とか逆から綴るやつとかあるので、うっかりしそうな人は上司が滝行に出してやるべき』
tomocha  『確かにそうですね。ただ、マクロが含まれていると、最近のオフィスはマクロがあるので、実行を許可するか求めてくるとおもいますが、出てきたら、問題ないものか確認しましょうというフローでも大丈夫かと。 正しくない拡張子をつけて。。。だと、確かに気づけませんね。でも、戻さないと正しくアクセス出来ないので、その時点であれ?と気づくのかな。 まずは、拡張子、ファイル名を意識するところからしっかりと始めると、大半は防げるのかもしれません。ただ、本気でねらわれて、正規のメールを偽装(fromや名前などすべて正しく記載されているケース)はこの方法では防げませんが。 』
[ コメントを読む(2) | コメントする ]

[Security][Network][Neta] Panasonic Switch-M16eG を購入・不良・交換したら YAMAHA RTX1200になり、納品物には設定済み。そのままフレッツにつないだら繋がるかもしれないが、不正アクセスになる?

福岡デイリーサービスという会社から、YAMAHA RTX1100および、 Panasonic Switch-M16eGというスイッチが安く出ていたので、全台(7台)を購入した。

このシリーズで有名なのは、PoEスイッチとして、Panasonic製の監視カメラの組み合わせて使うケースが多いと思う。もちろん、そのほかのメーカーであれば、Apresiaなども有名。

でも、今回購入したのは、非PoEモデル。 何がよいかというと、高温でも使える、FANレス、省エネモードがついてるインテリジェントであり、LinkAggregation、VLAN、SNMP対応、ミラーポートなど、最低限の機能などもつかえる。SFPポートも搭載している、高負荷をかけた状態でも15W程度ということだ。無負荷であれば、ワットチェッカーではかったところ、5Wを切り、測定不能というレベル。まとめると下記のような感じ。

島ハブとしてはとてもよいソリューションだ。RTX1100は1500円で出てたということ、まとめて買うなら送料が。ということで、現在動いているRTX1000が壊れたときのコールドスタンバイ。

現在はこんな感じで、今のところ壊れる様子もないが、いつ壊れてもおかしくない。

GW-RTX:> show environment
RTX1000
  main:  RTX1000 ver=XX serial=XXXXXXX MAC-Address=00:a0:de:XX:XX:XX MAC-Address=00:a0:de:XX:XX:XX
         MAC-Address=00:a0:de:XX:XX:XX
CPU:   5%(5sec)   8%(1min)   8%(5min)    Memory: 31% used
Firmware: internal  Config. file: 0
Boot time: 2009/12/31 03:07:21 +09:00
Current time: 2016/07/13 22:56:36 +09:00
Elapsed time from boot: 2386days 19:49:15

もう、2300日超えた。そろそろ6年ちょい。この機器を導入して、優に10数年。でも、いつお亡くなりになるかわかりません。

で、本題に入ろう、Panasonic Switch-M16eG を 合計7台購入して、うち2台、高周波音という異音を出す筐体が2台あったので、交換もしくは返品をお願いした。
しかし、交換品はない、返品も受け付けない、代替品で手を打たせてくれという。
で。代替品の提案がこういう内容。いや、調べろよ。

交換品のスペック等分りませんが...
NEC QX-S3126T-BS

交換品の提案が、 NEC QX-S3126T-BSで100M 24ポート、アップリンクにGigaポートがあるモデル。 全ポートGigaで省電力というものを購入しているのにもかかわらず、100Mのスイッチですよ。意味が全くない、てかゴミ。スペック知らずに適当に押しつけるのはどういうことかと。まずこの時点で対応がおかしい。
「要件(orスペック)があわないかもしれませんがいいですか?」
と聞くのが筋。
全ポートギガで省電力のインテリジェントでないと意味がないということで、突っ返したところ、「 代替品にYAMAHA RTX1200 2台でどうでしょうか。8ポートのSwitch-M8eGも2台つけます。」 ということだったので、手を打った。これは、ルータであり、HUBではないが、本当はRTX1100ではなく、1200がほしかったので了承。 8ポートのものもついたということで、合計16ポートになった。ラッキー。

届いたルータを確認していると、ログインできない。あら、気を利かせてくれて、設定をいれておいてくれたのか。ふむふむ。 パスワードなどの諸情報を教えてもらってないので、とりあえず時間も無いし、パスワードリカバリしよう。

YAMAHA ルータの場合、シリアルコンソール経由で操作するばあい、デフォルトパスワードとして、「w,lXlma」を入力すると、管理パスワードが不明でも管理モードになれる(詳細: 4.10 セキュリティクラスの設定)。ふむふむ、ログイン成功。てことで、こんな感じ。

ほ、ほう、親切に、VPNの設定とISPの設定をしてくれているじゃないですか。
事前に配線する前に、コンソールでつないで設定を確認したけど、このままフレッツにつなぐとPPPoEでASAHINETにつながっちゃうのかなぁ。
これ、 納品されたものに初期設定しておいてくれたものなので、使ってよいってことなのかなぁ。よくわからない。
これが、 不正に渡った、もしくは設定されていたアカウントなら、購入・納品されたルータをフレッツおよびLANに配線、設定しようとしたら繋がっていたというだけで、不正アクセス禁止法に引っかかるのかしら。 私は専門家でもなんでもない一般人なので良くわかりませんが。もし、ひっかかったら誰が罰せられるのだろうか。いや、ルーター安く買えた、とりあえずつないだらネットにつながった〜。っていうのは十分に考えられるシナリオ。

とりあえず、DDNSで osakanameosaka.aa0.netvolante.jp という名前が登録されていたので、調べてみよう。さらに接続先のホストに対して、osakanametokyo.aa0.netvolante.jp というのもあった。

$ host osakanameosaka.aa0.netvolante.jp
osakanameosaka.aa0.netvolante.jp has address 110.4.151.77

$ host osakanametokyo.aa0.netvolante.jp
osakanametokyo.aa0.netvolante.jp has address 14.3.35.187

$ ping 110.4.151.77
PING 110.4.151.77 (110.4.151.77) 56(84) bytes of data.
64 bytes from 110.4.151.77: icmp_req=1 ttl=241 time=32.8 ms
64 bytes from 110.4.151.77: icmp_req=2 ttl=241 time=27.3 ms
^C
--- 110.4.151.77 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms

$ ping 14.3.35.187
PING 14.3.35.187 (14.3.35.187) 56(84) bytes of data.
64 bytes from 14.3.35.187: icmp_req=1 ttl=242 time=24.0 ms
64 bytes from 14.3.35.187: icmp_req=2 ttl=242 time=19.9 ms
64 bytes from 14.3.35.187: icmp_req=3 ttl=241 time=20.0 ms
^C
--- 14.3.35.187 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 19.985/21.381/24.063/1.896 ms

ほ、ほう、生きてるのね。

ついでにこういうものもある。昔、2010年頃、YAMAHAがDDNSの移設をしたときか、ウォッチしていてミラーしたもの。

うん、2012/11/3の段階ではなかったレコードのようだ。
ということで、configを眺めてみると、VPNが3拠点はっているようで、descriptionからみると、大阪、福岡、東京の3拠点だった。

次に2台目を調査してみたところ、下記のような設定が入っていた。


(スクリーンショットをとるときに間違えてjpgにしてしまったらしく画質が...)

設定を確認すると、alpha-web.ne.jp って大塚商会。今はヴェクタント(現アルテリアネットワーク)のローミング。
最近、アルテリアのフレッツは品質落ちてますねぇ。。ココ。

脱線しちゃうけど、我が家の環境はISPはちがえど、アルテリアのローミング回線。RTTはこんな感じ。平日日勤時間帯のみRTTが40msぐらいまでのびる。この現象はここのところ最近のsmokepingの結果。ちなみに内部からではなく外部の契約しているDC上にあるネットワークからからsmokepingを仕掛けている。


参考に終端されているNTE側

明らかに法人ユースで平日日中帯だけRTTがのびる。
フレッツ側の終端はほとんど揺らがないが、アクセス側だけ揺らいでいる。

話を戻して、configんでいくと、記述方法が違うこと(特にフィルタ周りとかの定義の仕方)、互いに繋がっていないこと、ISPもIPアドレスも違うということもあり、この納品された2台は組が違うようだ。てことは、拠点の一部のルータが流れてきたってことか。

さらに調べていると、大塚商会にVPNソリューションというのがあり、 大塚商会 YAMAHA VPNルーターというのがある。ここのサイトによると、「大塚商会は導入から運用管理までワンストップで対応します。」と記載。これだったらおもしろいな。

いろいろとconfigをみたり、分析したりすると、おもしろいなぁ。それとも、わざわざRTX1200を設定済みのものを渡したって事は、引きこもりの末端作業員にVPNで接続してなにか仕事しろってことなのだろうか。うん、おもしろい 福岡デイリーサービスという会社であった。

まあ、どういう経緯で渡されたか不明だけど、設定済みのルータを配るときは危険なので、注意しましょう。てか、設定消せよ。まあ、configで、みられたらまずいものは、 4.10 セキュリティクラスの設定に記載があるとおり、forget off にしておくべき事案ですね。
ということで、中古で買うときは通電のみとかジャンクを買うとおもしろいですよ。てか、古物商やるなら、責任を持つというのを免許の項目に入れるべきではないか。情報漏洩する元は、販売する会社に問題があるということですね。

あと、福岡デイリーサービスという会社名を検索すると、よろしい評判はあまり見あたらないが、まあおいておくとして、 PC Watch: RITEA、中古情報機器取扱認定25社を発表という記事があり、調べていると、下記のような記載 が。

 PC等の普及に伴い、中古品の売買が増加したことで、HDD内のデータ未消去による情報漏洩問題が顕在化してきた。また、売買における基準や目安といった客観的な情報がないといった課題もある。

 これらの問題の解決のためRITEAでは、PC/サーバー/ワークステーションを対象に、良質な中古情報機器を取り扱う企業としての基本的な仕組み、中古情報機器の取扱に関する適切な業務処理の仕組み、ユーザーに対する適切な情報提供の仕組みからなる33項目の審査規定を設け、事業者に対して、買取(引取)、再生工事(データ消去)、販売、の3分野での資格認定を開始した。

もちろん、 一般社団法人 情報機器リユース・リサイクル協会 会員会社一覧にも記載があった。すなわち、正しく実施出来ていないもしくは、意図的に入れたまま出荷したというどちらかってことでしょうか。ま、後者だと思いますけどね(^^)

最後に)
私は設定済みのものをわざわざ納品してくれたという認識でかつ、購入したものを公開してはいけないというNDAなどは一切結んでいないので赤裸々に書いています。あくまでも商品を購入した側。またルーターメーカーの逆アセンブルを禁止するなどといったものにもふれておりません。センシティブなパスワードおよびシリアルナンバー、MacAddressなどは念のため伏せています。あくまでも購入したものをレビューしたにすぎませんので。
# IPアドレスから社名などわからないのでそのまま書いているし、書かないと他のストーリーが書けないから。


 別件で同じ業者から購入していたRTX1500は (8/13追記):



お見事っ!株式会社長崎ケーブルメディアのネットワークでがっつり使われていたようだ。
このアドレスの採番の仕方といえば、NCMから流れたものもしくはNCMと契約した顧客もしくはSIerから流れたものであるのはほぼ間違いないだろう。ちなみに、 法人向けIP-VPNサービスというのがあるが、こちらはMPLSやVLANをつかったとあるので、おそらくコレとは異なる可能性も。以前はどうかはわかりませんが。

おさっち  『Web Assistance でググると何台か出てきますよ。 レポート作成ボタンをクリックされれば、漏れ漏れですが。』
[ コメントを読む(1) | コメントする ]

2016年07月10日() [晴れ]

[Life][Internet] ルータリプレース、インターネットに繋がった♪

生活環境、テスト的にAristaのvEOSをいれてたけど、全く使い物にならないので、リプレースしたら、超快適になった。FreeBSD 10 + Quaggaも不安定だったので、Linuxに.... 安定性思考のFreeBSDはいずこ。てことで、安定しました。快適♪

ぃぇぃ

[ コメントを読む(0) | コメントする ]

2016年07月07日(木) [晴れ]

[DC] 日本ラッド目黒データセンターの取り壊しは平成28年7月19日から、事業主は伊藤忠商事株式会社でマンションが建つ予定らしい

(変更)「固定資産の譲渡及び特別利益の計上に関するお知らせ」の一部変更について
1. 変更内容・理由
本件の物件引渡期日及び物件代金入金日に関して、本日、引き渡しに必要な条件が全て確定したため、
平成28 年6 月30 日付で引き渡しを実行することになりましたので、お知らせいたします。

このIRをみて、6月末に引き渡しが完了したということで、解体工事がはいると、どこの会社が解体発注者かわかるため、現地に行ってみました。そしたら、見事に掲示されていました。

要約すると、次の通り

工事名称: (仮称)目黒区原町1丁目計画解体工事
場 所:   東京都目黒区原町1-22-3
工 期:   平成28年7月19日〜平成28年12月30日まで
事業主:   東京都港区北青山2-5-1
           伊藤忠商事株式会社
工事業者: 東京都港区芝浦3-17-11 ニュー協栄ビル
           株式会社合田工務店 (03-3454-6561)

掲示資料をみると、解体に当たり調査完了は平成28年3月24日 とのことなので、伊藤忠は3月の時点で解体に当たり建物の調査を実施していたとかんがえられます。

奥には、工事中の用に見えますね。

[ コメントを読む(0) | コメントする ]

2016年06月26日() [晴れ]

[Internet][NTT] 自宅のBフレッツファミ100は...

複数のセッションでも同様になっており、明らかにNTT側の問題と判断。
NTT東日本管轄からは、フリーダイヤルなど使えない。いろいろと困ったが、なんとか西ではないところから電話をかける方法を探し、電話したところ、NTT設備側では問題でていないということだったので、オンサイトによるONU、局からのレベル調査となった。

結局ONU交換で終わり。あーあ、長かった。てことで、この件があって、smokepingを仕掛けてみました。これ、ひどいよね。しかも発生するのは深夜帯のみ。意味不明。
交換後、この問題は出なくなったようだ。

[ コメントを読む(0) | コメントする ]

2016年06月16日(木) [晴れ]

[SPAM] 標的型攻撃メール

ここのところ最近ものすごく標的型攻撃メールが届く届く。
ほんと、糞食らえ。
ヘッダもよくいじられているし、それらしく見えるようになってる。
んで、最後に踏まれたホストは、k-opti のようだ

From ghostwrotepq2@ab.auone-net.jp Wed Jun 15 18:07:49 2016
Return-Path: <ghostwrotepq2@ab.auone-net.jp>
X-Original-To: tomo@XXXXXXXXXX.jp
Delivered-To: tomo@XXXXXXXXXX.jp
Received: from mx0.XXXXXXXXXX.jp (ns0.XXXXXXXXXX.jp [182.48.XX.XX])
        by mail.XXXXXXXXXX.jp (Postfix) with ESMTP id B85845C81F
        for <tomo@XXXXXXXXXX.jp>; Wed, 15 Jun 2016 18:07:49 +0900 (JST)
Received: by mx0.XXXXXXXXXX.jp (Postfix, from userid 65534)
        id B277E50EC1; Wed, 15 Jun 2016 18:07:49 +0900 (JST)
Received: from [218.228.253.122] (unknown [218.228.253.122])
        by mx0.XXXXXXXXXX.jp (Postfix) with ESMTP id DDC7450E67;
        Wed, 15 Jun 2016 18:06:46 +0900 (JST)
Received: from [56.102.176.82] (helo=knkta.fiaxfeeopv.info)
        by  with ESMTPA
        (envelope-from <noreply@mm.post.japanpost.jp>)
        id F449497F4AC3
        for tomo@XXXXXXXXXX.jp; Wed, 15 Jun 2016 17:45:37 +0900
Received: from [156.113.193.181] (helo=wquh.nuz.ab.auone-net.jp)
        by  with ESMTPA
        id 60BC9DF6F8
        for tomo@XXXXXXXXXX.jp; Wed, 15 Jun 2016 17:45:37 +0900
MIME-Version: 1.0
From: <noreply@mm.post.japanpost.jp>
Reply-To: <noreply@mm.post.japanpost.jp>
X-Mailer: Zimbra 8.6.0_GA_1162 (ZimbraWebClient - FF44 (Linux)/8.6.0_GA_1100)
Date: Wed, 15 Jun 2016 17:45:37 +0900
To: <<tomo@XXXXXXXXXX.jp>,
        <tomo-mldd@XXXXXXXXXX.jp>>
Subject: =?iso-2022-jp?B?WxskQkZ8S1xNOUpYGyhCXSAbJEI9ODJZME1Naj89OX4kXzQwTjskTiQqQ04kaSQ7GyhC?=
Content-Type: multipart/mixed; boundary="----=qV-jdPZzUfxmHlRT_PRv3Wga"
Message-ID: <da444e16ec50b2984946@xlzct.zrgohyhac.ab.auone-net.jp>
X-URIRBL: No, test=check_uri.pl, version=1.50

------=qV-jdPZzUfxmHlRT_PRv3Wga
Content-Type: text/plain; charset="iso-2022-jp"
Content-Transfer-Encoding: 7bit

受付番号:S16059317887588

この度は日本郵便のWeb集荷サービスをご利用頂きありがとうございます。
上記の受付番号は、お問い合わせ・内容修正・申込取消の際に必要となります。
このメールを保存または印刷していただくよう、よろしくお願いします。
お申込み内容は以下のとおりです。
----------------------------------------------------------------
電話番号:0157-52-2311 内線:

集荷希望時間帯:15:00‐17:00

商品:ゆうパック
個数:1個
送り状の用意:用意済み

----------------------------------------------------------------
なお、このメールアドレスは送信専用となっております。
本メールに返信されましても、ご質問等にお答えすることは出来かねますのでご了承ください。
〒------------------------------------------〒
日本郵便株式会社
〒100-8798 東京都千代田区霞ヶ関一丁目3‐2

 ゆうびんホームページ
 http://www.post.japanpost.jp/
〒------------------------------------------〒

------=qV-jdPZzUfxmHlRT_PRv3Wga
Content-Type: application/zip; name="POST.44369462486191360932 PDF.zip"
Content-Transfer-Encoding: base64
Content-ID: <000601d1c72d$b9af3c60$c70210ac@FMB491QC>

そのほか、こんなやつも。

阪本様

お世話になっております。
月額管理費ですが、月額507,000円で認識はあっていますでしょうか。
宜しくお願いします。
[ コメントを読む(0) | コメントする ]

2016年05月21日() [晴れ]

[] 大久保西の茶屋

お隣さんの大久保西の茶屋に足を運んでみましたw というか、突進ww
~


入ると、漬け物、お茶、みそ汁と着弾。



一人一品頼もうとしたら、6人だと、「団子もついてお得な6人前があるよ。」
ということで、6人前相当のファミリーざるそば、追加オーダーで、山菜天ぷらの盛り合わせ。


蕎麦の海!!
思った以上に多い!



天ぷら、サクサク。



団子。かなりきつい、おもたい。



そばの香りすばらしく、つゆのバランスもとてもよく、美味しい。
だけど、噛んだときの腰はほとんどなくて、のどごしと蕎麦の香りをたのしむタイプ。
そばはこの香りで、さっきのお店のようなお蕎麦とがだと最高かも。
どっちも美味しかったー。ごちそうさまでした。

好みでいうと、お蕎麦は大久保の茶屋で、汁は、大久保西の茶屋。
不思議な関係。
ちなみに大久保西の茶屋は、お節介な感じの女将さんがいて、ちょっと面倒と思う人はだめかもしれません。最後までクレープがおすすめよとずっと推し薦めてきました。

[ コメントを読む(0) | コメントする ]

[] 大久保の茶屋 @長野県長野市豊岡

知り合いに、お蕎麦好きなのという話をしたところ、とてもおすすめよと教えてもらった、長野県長野市豊岡にある大久保西の茶屋のお蕎麦。
実は、今年の2月の出来事なんだけど、ものすごく気温が上がってしまい、さらに雨。気温は日中18度とか。
白馬にきているのに、雪がない、雨降るという事案が発生して、長野市内の観光と蕎麦巡り。

大久保西の茶屋は本店以外にもあって、本店がおすすめよ、といわれたので現地に行ってみると、大久保の茶屋というのがあり、ぱっとみて、意味がわからず、同じ系列なのねとおもい、駐車場に近い方に入ってしまった。



駐車場にはいるとこんな感じ。


ということで店内へはいると、時間がピークを去ったのか、そもそも人気がないのか、比較的空いていた。
メニューを眺め、どのお蕎麦を食べようか。。。








ということで、お通しじゃないですが、野沢菜。いやー、野沢菜とお茶ってとってもおいしい。


ここのお茶もおいしいので、この組み合わせがとても幸せ。パクパク食べてしまい、お変わりをいったら、出してくださいました。
のんびりしていると、お蕎麦が到着。



う、美しい。。。お蕎麦の麺か少し太め。



香りはさほど強くないように感じる。 コシはしっかりしてて食感とのどごし共に良く。
お店の人に聴くと、経営も、スタイルも、お隣さんとは全く違って別物ですと念を押されてしまったので、スイッチが入ってしまったのか食べ比べモード。さあ、次いくよ〜!

[ コメントを読む(0) | コメントする ]

[] 馬力屋 @埼玉県鴻巣市

昨年のif山岳ラリーのオフィシャルのあと、諸事情で人を送り届ける事になった。おすすめのお蕎麦やさんがあるよって事で、訪問。
どうやら、お店の建て替えか何かでご両親が関わった昔からなじみのあるお店だとか。
昔は、空いてたのに、今は人気店担っちゃったみたいで・・・といわれ、13時頃到着しても、30分ほど待つことに。



メニュー




かも汁蕎麦をオーダー。


どうやら、平べったいおうどんも有名だそうです。
平べったいおうどんは、日本一の川幅を持つ荒川 *1 にちなんで、おうどんも名物とか。
お蕎麦がとてもおいしかったので、ざるそばも追加オーダーしちゃいました。
雰囲気も最高、味も最高。




近くだったらまた、立ち寄りたいですね。

手打ちそば 馬力屋
048-542-9055
埼玉県鴻巣市滝馬室948-2
11:30〜14:30, 17:00〜20:30
定休日:木曜の夜(念のためお店に確認してください)


*1: 鴻巣市滝馬室と吉見町大和田との間を流れる荒川の川幅が全国最長らしい
[ コメントを読む(0) | コメントする ]

[] そばの里 永野 @栃木県鹿沼市

ラリーで鹿沼の方へ。
朝市に移動し、ちょっと早く現地近くまで到着したので、お蕎麦食べたいね、ってことで、訪問。
到着は10:40頃でまだ、オープンしてないけど、地元の人が、今日収穫されたものや、朝からお仕事終わった人たちなどが集って、周りでのんびり田舎モード。ジジが多い感じ。
こういう感じ大好きよ♪



しばらく待ってると、オープン。
お外のテラスエリアでしばらく待たせてもらい入店。



頼むのはお蕎麦と、山菜の天ぷらを頼もうと決めていたので、オーダー。
どうやら、このあたりはニラ蕎麦が有名とのこと。
それがね、結構あうんです、ニラ。
奥の方で、おばさま方が10人近い人でこしらえていたりして、忙しそうでした。



意外な組み合わせでおいしくいただき、次は天ぷら。


かき揚げとクレソンかな?よくわからなかったけど、さくっと、ふわっとあがっており、おいしい。
お蕎麦は一風変わったものだけど、感動するものはなかったが、そこそこおいしい。まあ、このコスパならありやね〜。

お店は、田舎の蕎麦屋というか食堂という雰囲気に近い感じでテーブル。
オープンとともに、地元の人が入っており、ビールを頼んでたりするいわゆる集会場な雰囲気になってました。
そして、定休日は月〜金というすごいところ。

そばの里 永野 (ながの)
0289-84-0078
栃木県鹿沼市下永野1314
11:00〜16:00
定休日:月曜〜金曜

[ コメントを読む(0) | コメントする ]

2016年05月20日(金) [晴れ]

[Neta] ポリ公

どうやら、サミットが近いようで、東京駅を通ると、犯人はオマエダっ!という顔。
しかもマスクで顔をかくしちゃって、照れ屋さんだねぇw


あつい視線とまなざしを贈ってくれるので、しっかり何枚も連射してあげましたwww
そして、さらす。
おいら、オマワリは嫌いなのでじろじろと眺めてあげるのが好きです。

[ コメントを読む(0) | コメントする ]

[] フレッシュネスバーガー:生ハムアボカドサンドを食らいつくす

プレスリリースはこちら。
メルマガで、

★クリーミーな生アボカド、香り高いプロシュート、北海道産マスカルポーネチーズ、バジルソースを贅沢にサンドしました!
★『アボカドバーガー』『アボカド&ベーコンサラダ』など生アボカドを使用したメニューを取り揃えております!

女子力のないおっさんが女子力アピールするには、ラーメンや餃子、カレーばかりじゃなくて、こういうのもたまには食べてアピールしなきゃってことで、早速いってみました。



生ハムたっぷり、カットされたアボカドが4つ。
かじってみるとしっかり、しっとり。
もっと生ハムほしい(笑

おいしゅうございました。生ハム今の3倍ほしい!

[ コメントを読む(0) | コメントする ]

2016年05月19日(木) [晴れ]

[] 喉黒をいただく会

今回はスポンサー様がいるお食事会、ある意味青天井....な感じだったのですが、まあ、、お察しを。。
~
いやぁ、なんやかんやで、WIDE関係者が多い会だったのですが、「suguru!悔しかったら戻ってこい、おいしいもの食べたかったら戻ってこい!」といっておいしいものをいただきました。。



喉黒の刺身。
一皿、2500〜3000円ぐらいといってたような。。とりあえず4皿を3人でパクパク。


2皿並べてみましたっ
甘くて、脂がたっぷりのっていて、臭みが全くない!これならおいしい!


次は牛タン。
仙台牛タン風かな?普通。


今日の魚ということで回ってきました。
コレが食べたいといってオーダーできるようです。


次は、八海山大吟醸! 日本酒の中でも一番高い、14800円。普通に酒屋で買っても4500円前後。
仕入れ値の3倍の価格ですね、1本売れると1万円の利益。


刺身と牛タンと日本酒、やばいね、これ。


次は、ステーキ、ハラミ!


さあさあ、喉黒の煮付けがきました。煮付けだよ、煮付け。
魚が苦手なので、食べれないかなと思い一口。うん、食べれた。
すなわち、食べれないのではなく、おいしいものじゃないと受け付けないってことか(笑




次は伊佐木。
こいつは苦手。でも、ほっけみたいなかんじ?




後はバカスカ日本酒はいるなりと、、、お一人様のお会計はわかりません、やばい。
本当にごちそうさまでした。。。

今日は、お弁当食べて、カフェタイムやって、ケーキ食べて、料亭みたいなところでお料理いただいて、優雅な一日でした。毎日でもいいね!ああ、すばらしい、OL日和でしたっ!

[ コメントを読む(0) | コメントする ]

[] 仕出し弁当とケーキバイキング

本日のランチは、仕出し弁当。
あー、頂き物だけど、食べれないものがあったので、一緒にいた若いツバメ(♂)に差し上げ。
いやー、でも、カワイイお弁当でした。
味もおいしく健康的。おいくらぐらいするんだろうか。



ご飯が別盛り!


ご飯もおにぎりになってて。ま、仕出しだしね。

ちょっとランチ弁当のあとはニートで引きこもりの私は、ちょっとカフェ、しかも景色の眺めのよいところで、ケーキバイキング。
写真は、チョコ。みてわかるよね(^^)
ほどよく苦く、甘さ控えめ。コーヒーととても合う。


ケーキコーナー。
品数は少ないけどおいしい。ちょっと甘め?
この後にチョコケーキをいただくと、味が・・・。


お皿に盛りつけてみた。
中心がずれてるのはうれしすぎて、撮影失敗、ご愛敬(笑)


フォーカスをずらしてみた。
景色はのどかでいいねぇ。


やっぱり、フォーカスはこっちでしょ(笑


第二弾のケーキ。いやー、3時間ぐらいまたーりケーキいただいたりコーヒーいただいたり充実した時間でしたvv
引きこもりでスポンサーいるってすてき♪

[ コメントを読む(0) | コメントする ]

2016年05月12日(木) [晴れ]

[Life][Internet] 訃報:山口英先生

山口英先生とは、学生時代の出会いでいろいろとお世話になった方が、9日になくなったとのこと。 緘口令を敷かれておりしばらくかけなかったのですが、TwitterやFacebookなど一次情報がないため、WikiPediaの投稿などによる憶測が広まっていました。
どちらかというとプライベートな方でのおつきあいで、きっかけはNAISTやWIDEといったところでしょうか。suguru先生(愛称すぐすぐ先生)が単身赴任中、趣味が料理的なところや食べ歩き的なところがあり、おいしい角煮の作り方とか、おいしい担々麺のお店とかいろいろと教えてもらったものです。。そのほか、学生の頃、奈良先端大に 住みついていたりして、

「今日は上品な飯と下品な飯(ラーメンやがっつり系、がっつり亭とかのこと)どっちがいい?」

といって、 学生たちと一緒にご飯をたべたり。そういう思い出がいっぱいです。そのとき、今日の車はZだから、とか二人乗りやわ、学生の車でいこかとか。
そのほか、 IPLabの研究室合宿に参加したりて、学生とはじけてジーパンに穴を開けるということがあったりと、楽しい時間を過ごさせていただきました。

本当にご冥福をお祈り申し上げます。。
この話を聞いた夜は眠れませんでした。いろいろと思い出してしまって。

関連記事

[ コメントを読む(0) | コメントする ]

2016年04月22日(金) [晴れ]

[] 丸高屋 西三島店 @吟醸みそラーメン

その後おぬぬめというラーメンにアイスを食べながら向かいました。
お店に着くと、20人ぐらい並んでたものの、15分ほどで入店。
大吟醸味噌らーめんのお店で味噌が売り。



写真を見てもチャーシューすごい。


やっぱり、看板メニューである大吟醸味噌かなということ、特徴的なチャーシューということで、大吟醸味噌をいただきました。



ラーメンはおいしい。でも、甘い。吟醸味噌ってそういうことなのかな。
とても丁寧なラーメンで札幌的な雰囲気かと思いつつも全然違うラーメン。
味噌の味がたっており、味はかなり濃いです。


餃子はなんの変哲もなく特徴もないラーメン屋さんの餃子。 オーソドックスなので、これならなくてもいいかな。
:IMG ./img/2016/20160207o.jpg n ./img/2016/20160207o-small.jpg

ジンギスカンを食べた後にはとてもきついラーメンでした。
お店の雰囲気的には、お店のスタッフも明るく、サービスや気配りもよい気持ちのよい店でした。
おいしいラーメンではあるけど、私の舌が肥えてしまったのか、東京で食べれるラーメンと比べてしまうと、少しインパクトに欠けてしまいます。
ただ、地方などでがんばるにはとてもレベルが高いラーメンなので、これからもがんばってほしいですね。

丸高屋 西三島店
0287-36-8180
栃木県那須塩原市西三島4-183-3
11:30〜22:00


[ コメントを読む(0) | コメントする ]

[] そうだ、あんこの家にいこう!そして、千本松牧場にいこう!

国道4号線を走行中、そうだ、栃木といえば、@koshian だっ!いま、日本に滞在してるよね!と頭の中をよぎり、Facebookメッセンジャーで、朝の9時頃にメッセージ。

私「4号で栃木入った。飯付き合ってww 福島脱」
あ「おいら寝てないんだよなあ。何時に着きそうなん?」
私「いま、なす。いえどこだっけ」
あ「○○だよ、座標送る」
私「お、出てきた、あと15分ぐらいらしい!」
あ「メシにははやくねーかwwww」
私「だなぁ!じゃあ、寝る!もしくは宇都宮に行こう!」
あ「むりだwwww ヒゲも剃ってないし歯も磨いてないぞw」
私「ついた」

ということで、家の前についたら、知らない車が止まってるよ、とあんこのお母様が気づいてくれたよう。
毎度、無鉄砲でごめんなさい。
おこたで12時頃まで仮眠をとらせてもらい、その後、こしあんとお食事デート(むふふ)

ジンギスカンにいこうぜ!ってことで、 千本松牧場のジンギスカンとアイス。
だだっぴろい駐車場に止めて構内を散策。





雪が残ってるね。


さて、目的のジンギスカン。
ジンギスカンは、食べ放題とセットの二つ。
近くにおいしいラーメンあるけどどうする?っていわれて、じゃあ、両方に決まってるやん!てことで、食べ放題にせず。


独特な焼き方をするスタイル。
ちなみにほとんどセルフでお肉は少し凍ってる。野菜の上で蒸す感じがおすすめとか。


焼くとこんな感じ。
うん、おいしい。こういうのもいいね。ジンギスカンは野菜をたくさん食べれるから好きなのだ。


ここのアイスもおいしくて、ここ以上においしい店知らないってことだったので、そりゃー、デザート必須でしょ!
アイスコーナーへ。


アイスどーん!
濃厚、うんまうんまっ!


あんこに教えてあげる。ここもおいしいけど、負けないぐらいおいしいと思うお店あるのよ。
それは、山梨県清里にある 清泉寮 ジャージーハットもとってもおすすめ。ここも濃厚でとってもおいしいですよ!


アイスを食べながらおみやげコーナー。ラクトアイスもおいしいよってことで、コレも食べなきゃって(ぉぃ)


ずんずん!


どーん!


おみやげの6個パックとかのほうが、単独で買うより高い。普通逆でしょ。っていいたい。
まあ、保冷剤と発砲スティールの箱にはいるにしても、ちょっと高杉やしないでしょうか。
てことで、保冷剤はもらえるので、クーラーボックス持参をおすすめします。
こっちはこっちで、濃厚でおいちー!

[ コメントを読む(0) | コメントする ]

[遊び][] スキーの後、福島へドナドナして車中泊、栃木で放浪したよ

今シーズン3度目のスキー。滑って転んで遊んで。今年はボードは封印。
昨年骨折したので(わら

てことで、出発前にガソリン満タン。
レギュラー99円、ハイオク105円、そこから13円引きなので、実質92円。


川場スキー場で滑った後、早めに撤収して、温泉、ひゃっほー!


東京に着いたのは19時頃。
実は前日に、雪が降ったし、雪かきしない!?と電話があり、タイミングが合えばいくよ〜!ってことで、19時半頃東京に到着。
その後、練馬から高速に乗って、福島方面へ。
雪かきって、車で雪をかくという練習。

待ち合わせの場所は、黒磯板室PA。遅れ気味だったので、ちょい急ぎ気味で向かったのですが、他の人はいない。。
さらに遅れてたとか。時間にルーズだなぁ(笑

さて、そこで合流して目的地へ。
私は、運転がド下手なので、慎重にゆっくりゆっくりと雪道にペースを上げながら降りる練習。もちろん登りも。

そしたら、普通の速度より遅い目に下っているにもかかわらず、きついヘアピンで雪かきしちゃいました。
徐行程度の速度にもかかわらず、荷重移動と減速のために、ブレーキを踏んだ瞬間ABSが効いてしまい、そのまま滑り落ちる羽目になり、強引にアクセルを踏んでも曲がりきれず。ほぼ無傷でしたけど、こりゃだめだってことで、ここはABSを切るしかないな!とおもい、ABSを切るという選択。勾配のきつい山の中ではABSは本当にじゃまでASBは事故の元で危ないな、というのが正直な感想です。

ABSをきったら、コントロールしやすくなり、むっちゃ走りやすくなりました。



インプレッサは、エンジンルーム内にあるヒューズボックスからABSとかいたヒューズを抜くだけでOK。
ABS切るとブレーキの感覚など変わる可能性があるのでということで、様子を見ましたが、特に変化なし。
ただし、同時にサイドブレーキのランプも点灯します。
なるほど、、、競技車がサイドブレーキのランプがつくのはここからなんですね。

先ほど曲がりきれなかったきついヘアピンも難なく曲がれるようになりました。
そして、雪道の峠で車をコントロールする楽しさを覚え、深夜3時頃に撤収。

帰り、力尽きて道の駅で車中泊。

寝る前がこんな感じ。


起きたらこんな感じ。


見事に車がww


寝る直前は外気温は-6度から-7度。
さらに気温が下がったと考えられ、-10度程度の可能性も

もちろん雪の中で寝るときはエンジンはきっちりと切ります。
ガソリンがもったいないというのもありますし、マフラーに雪が積もり、一酸化炭素中毒になる可能性もありますからね。
私は、氷点下2度までいける毛布兼寝袋2つと毛布を積んであるので、二重でくるまれば十分にあったか。
二つ積んでいるのは、特に寝てると体は平気でも足下が寒くなることが多いので、用意周到ですw
結局快適に夜を過ごし、起きたらちょっぴり寝汗かいてましたw

起きたら、室内の湿度も上がり、窓ガラスはなからも外からも凍って、さらにドアも凍って他ので強くあける必要がありました。
雪を払い、エンジンをかけて、ガラスにつもった雪と氷をはがし、国道4号を走行して帰ることに。
帰る途中思い出したかのようにあっ!あんこがいる!!!(つづく)

[ コメントを読む(0) | コメントする ]

2016年04月21日(木) [晴れ]

[Internet] DNS Onsen2 補講@IIJ飯田橋

3/26日に行われたDNSOnsen補講のとある@tss_ontap先生の資料。爆笑。



何も言うまい。。。
書式はいいから、実値を埋め込んで実例を元に、毒を盛ってほしい!(くふ)

[ コメントを読む(0) | コメントする ]

2016年04月20日(水) [晴れ]

[] 台湾料理 三福源 桜区五関店でセット+唐揚げを食す

ここの唐揚げは絶品で頼むべき一品と一緒にいた人に言われ、チャレンジ。

待つことの10分程度。
着どーん!


iPhone5と比較。


メニューの写真と比べても明らかにでかいんですけど、、、、。
さすがに無理っ!
できたては超おいしい。油もきれいなものつかってるし、ふわっと、からっと、ジューシー。




ランチなので、お得なランチセットを検討すると、で、でかいっ!


台湾ラーメンとニンニクチャーハンをオーダー。


セットのチャーハンのサイズがコレですよ、、、。


ふつうだけどボリュームたっぷり、コスパ最強。
なににしても、唐揚げでかすぎ、スケール感半端ない。。本当にごちそうさまでした。
食べきれずに半分持ち帰りました。それでも、横に大きくなりそうです。。。w

三福源 桜区五関店
048-859-2938
埼玉県さいたま市桜区五関85-1
11:30〜14:30 17:30〜24:00

[ コメントを読む(0) | コメントする ]

[] 宴会

こっちは新年会を兼ねたほうのイベント。今更ですが。
恒例毎年同じ民宿の 川崎屋にて、お世話になっているようで、かなり豪華になってるようです...
ちなみにおいらは食べれるものは数少なく...~
あ、そうか、ひたち市は海沿いだった、魚がおいしい町でした。

すでに豪華...

アワビ、ウニ、ほかいろいろ...


グラタン、キッシュ。どちらも魚介ふんだん...


日立牛


お造り


イノシシ?鍋


もつ鍋


鍋をいただきました。うまー!
にしても、一つの鍋を4人の配分。いや、鍋だけでおなかいっぱいになりますよって..
なんか、もったいない感じが満載でしたが、その後部屋に持ち帰って遅くまで宴会に。
それでも残るぐらいだったのでした。。

その翌日の帰り、太平洋側をドライブしながらかえりました。
1月というのに風が気持ちよかったので、撮影w(あほw









朝なので光と海がとてもきれいです。ああ、おいらの人生よ、海辺でうふふ、きゃっきゃという出会いはないのかしら(^^;

[ コメントを読む(0) | コメントする ]

[] 1ポンドハンバーグ@ぶどう亭

ラリー走行会の後、本日は、肉にいこう!ってことで、ステーキやハンバーグのぶどう亭。
いやー、すごいね、1ポンドサイズのハンバーグにご飯大盛り。げふっ!



みよ、このジューシーな肉汁!


1ポンドといえば450g、450gですよ、先生。
写真でみたら、ふつーのサイズなんだけど、よんひゃくごじゅーぐらむ。
小食なあたしには、胃袋におさまりゃしませんよ。
ネタでやって、一緒にいた人に押しつけようとして注文。

とか冗談いいながら、さくっと食べれてしまいました。
ミディアムぐらいでとオーダーしたら、ビーフ100%じゃないので、完全に火をとおしますってことでした。
ファミレスやガスト系列と比較しちゃだめだけど、まあまあおいしいハンバーグでした。

それ以外にも1ポンドシリーズはあるので、是非お試しを。


ぶどう亭
029-295-2911
茨城県那珂市後台3331-1
[月〜金] 11:30〜15:00 17:00〜21:00 [土・日・祝] 11:30〜21:00

[ コメントを読む(0) | コメントする ]

[Drive] アベレージラリー走行会参加してみたよ

実は、わたくし、今シーズンはとあるラリーシリーズにほぼ出走予定なのですが、勉強と練習もかねて、今回はすべてナビで参加を予定しています。 第一戦で失敗した部分を克服すべく練習会への参加なのです。というこで、ドライブしてるよ〜〜!!

春なので、さくらがきれい。



さくら


コマ図にかき込んで作ってるよ〜!
いろいろと書ききるのが難しいのです。ミスや漏れがないように工夫をするだけで一苦労。。


ラリーでとても困るのが、途中にお手洗いにいきたくなったとき、どうしようもないのよね。
という話をしてて、女性が参加しにくい理由ってここにもあるんじゃないかな〜?といってたら、強制レスコンがコース上に設定され、お手洗い休憩が十分にあったことがとてもありがたいです。
今回のミスはほぼ0。だけど反省点もいくつかあって、次回の本番に生かすことにします!
NONOを使った時間走行の操作がとても難しく、何度やってもなれれないのです。。。困った困った。。
今回克服、次回で成果だせたらいいですね。

[ コメントを読む(0) | コメントする ]

[][] こはく@東海村

今年の1月下旬にラリーの走行会と新年会をかねて、東海村にお邪魔しました。
その後、4月上旬にもラリーの走行会で東海村に訪れたとき、二度目の訪問。
ということで、今回は2本立ての日記です。

最初東海村を訪れたとき、ランチはなににしようかな〜?とおもって自然薯が食べたい!とおもい探したお店が、こはく。 自然薯は、鉄腕ダッシュや青空レストランをみて、食べたいと思っていた食材の一つ。
今回念願の自然薯をいただくことができました。
食べログなど全然情報がなくて、 個人ブログが引っかかる程度。
まあ、小鉢も豊富だし、入ってみるかな〜?とおもい訪問。



入店時刻はお昼前。店内に入ったがお客さんは誰一人おらず、実は地雷店?と思い、メニューを広げてみると、あっちゃー、とっても高い。


入り口にあったランチメニューもメニュー表になくて....
ランチメニューって何だっけ。。地雷かも。。とおもい尋ねてみたら、日替わりメニューをおいてなかっただけでちゃんとあったようです。
私は目的の自然薯のランチをいただきたかったので注文。

しばらく待つことの十数分。20分近かった気も。



しっかりした御膳。ああ、実はあたりかもっ!?と実物を見て感じました。
ご飯は多めに!っていったら多めにしてくれました。


自然薯
濃厚。ああ、ねばねば混ぜたくなる。


刺身


小鉢


刺身も新鮮で、小鉢も田舎の味という感じでほっとします。
さて、自然薯でねばねば遊びモードに入ってしまい...`
ぐるぐるぐるぐる。


つかんでみて〜♪


どろーん♪


実はこれ、出汁をいれてのばしているのでかなり柔らかくなってるけど、出汁を入れる前はもっとねばねばなんだよと女将さんが教えてくれました。
その状態のものを食べてみたいです。醤油とわさびでご飯にのせて食べるととってもおいしそう。
自然薯は、 じねんじょうんちくによると、「日本原産の野生種で、「自然生」などと呼ぶこともあるようです。その名の通り、自然に生え、山野に自生している貴重な品です。」ということで、自然に自生した山芋ともいえるそうですが、「ナガイモと自然薯はとろろにするとよく似ていてわかりにくいのですが、染色体が異なり、植物分類学上では明らかに違う種類だとされています。自然薯は栽培の山芋とは粘りも風味も格段に違います。」ということで、山芋や長芋などとは違うもののようです。
粘りけは山芋と段違いというのが、さっきのねばねば遊びでもおわかりでしょうかw


最後、とろろご飯にして胃袋にかき込み、その後はデザート。


コーヒーまで付いて、1380円でした。

実は結構お得。

そして、4月頭にも走行練習会があり、東海村にお邪魔したとき、前回いただいた自然薯が食べたくなり、2ヶ月ちょっとぶりに改めて訪問。
今日は天気がよいですね。


本日のランチ。


店内にはいると、ドリンクバーができており、お茶やコーヒーなどはサービスになっていました。
肝心のメニューは前回と同じ。
ということで、自然薯を注文。


あれれれ?小鉢が一つ少ないし、前回より劣化してる気が...
でも、前回よりお刺身は少しグレードアップかな!?
今回はお新香だったけど、前回のおつけものはおいしかったなぁ...


刺身


小鉢


メインの自然薯


今回も混ぜ混ぜ、ぐるぐる。


ああ、おいしかった。でも、お値段が前回と同じでちょっとなんかむなしい。次回いくの考えちゃいますね。。。

日本料理 琥珀
029-282-2998
茨城県那珂郡東海村村松917-1
11:00〜14:00 17:00〜21:00
定休日:月

[ コメントを読む(0) | コメントする ]

2016年04月19日(火) [晴れ]

[Comp][Unix] ASCII Dowango 藤田昭人 Unix考古学 Truth of the Legend

この本、私が関わっておりまして、昨年の10月頃かな、学生の頃の意地悪でたくさんお世話になった先輩に呼び出され、「おいしいもの食べさせてあげるから、ちょっとおいで。」と。某ビルで打ち合わせ。そして、この本を手伝ってくれってことで、お手伝いすることになりました。
そんなわけで、とても豪華な肉の写真があったりと、いろいろとドワンゴ様にも先輩にもごちそうになったのです。
この本の読者のターゲットは、80年代、90年代の世代の人で、コンピュータの歴史を目の当たりにしてない人たち、そして、今の歴史を知らない人たちに読んでほしいということから、ちょうど私に声がかかったようです。
この書籍では、私のことをリアルにいじられていることも書いてあります。。。ったく。。
んで、4月19日の午後に本が刷り上がり印刷所からあがってきたようです。刷り上がったよと一報もらって、受け取ったのはその5分後。さすが同じ場所にいるだけありますね。近い。そしたら、藤田さんが、「ムカツク、、、」と。そりゃそうでしょうね(^^;;)



前書きに、よこたんこと、横田真俊さん前書き担当です。

今回お手伝いをさせてもらい、感じたのは、だって、「私、生まれてないし、そういう歴史って、聞くこともないし、そもそも情報のソースがあまりないので、これ本当なの?って調べながら読むのって大変。」ということで、ものすごく時間がかかりました。元々はUnixUserの再編であったり、新しく執筆された部分などもあり、UnixUserを当時読まれていた方も改めて手に取ってみるとよいと思います。懐かしい!っていう人もいらっしゃると思いますので、価値のある一冊にしあがっているとおもいます。あ、新入社員などの研修用の本にしてもよいですよ!

目次はこんな感じ。

第1章 プロローグ:Multics

1.1 Multicsの開発 ― Unix 誕生の契機
1.2 Project Whirlwind
1.3 ARPA
1.4 Multics

第2章 PDP-7 Unix

2.1 Ken ThompsonとDennis Ritchie
2.2 Multics Project 撤退直後の混乱
2.3 開発用コンピュータの調達
2.4 Space Travel
2.5 PDP-7 Unix
2.6 TMG
2.7 Programming Language B

第3章 First Edition Unix(Version 1 Unix)

3.1 私のグループ
3.2 起死回生の妙案
3.3 PDP-11
3.4 QED - Ken Thompson のバックキャリア
3.5 roff
3.6 First Edition Unix(Version 1 Unix)

第4章 Third Edition Unix(Version 3 Unix)

4.1 Small is Beautiful
4.2 1972-1973の状況
4.3 C 言語の開発

第5章 デビュー

5.1 学会発表
5.2 BBNのLISP研究
5.3 PDP-10の登場
5.4 デマンドページングによる仮想記憶
5.5 TENEXの人気
5.6 TENEXの評価

第6章 Programmer's Workbench

6.1 Fourth Edition Unix
6.2 1974 年から1975 年の状況
6.3 Programmer’s Workbench

第7章 Seventh Edition Unix(Version 7 Unix)

7.1 新たなスタンダード
7.2 Portable C Compiler(PCC)
7.3 Unixカーネルのポータビリティ
7.4 Interdata 8/32
7.5 Seventh Edition Unixの意義

第8章 Unix at Berkeley

8.1 Unixのサポート
8.2 UCBでのUnixの導入
8.3 PostgreSQLの祖先Ingres
8.4 そのころのUnixは?
8.5 50 Bugs

第9章 Berkeley Software Distribution

9.1 Unix 互換OS
9.2 Pascal: モダンなプログラミング言語
9.3 Pascal 誕生
9.4 UNIX Pascal System
9.5 Editor for Mortals

第10章 UNIX 32/V

10.1 BSTJ UNIX特集号
10.2 VAX-11/780への移植

第11章 Third Berkeley Software Distribution(3BSD)

11.1 Richard FatemanとMacsyma
11.2 仮想記憶機能のサポート
11.3 Third Berkeley Software Distribution(3BSD)

第12章 ARPANET

12.1 ARPANET (1) - コミュニケーションデバイスとしてのコンピュータ
12.2 1969年のアメリカ社会の情勢
12.3 ARPANET (2) - インターネット前史
12.4 DARPAと4BSD

第13章 4BSD

13.1 DARPAからの支援
13.2 4BSD
13.3 4BSDのパフォーマンスチューニング
13.4 4.1BSD

第14章 4.2BSD/4.3BSD

14.1 4.2BSD
14.2 4.3BSD

第15章 ワークステーションのコンセプト

15.1 コンピュータのパラダイム
15.2 パーソナルコンピュータのコンセプト

第16章AT&TとUnixライセンス

16.1 オープンソースの文化
16.2 巨大企業AT&T
16.3 独占禁止法訴訟とUnixライセンス

第17章 Unix Wars

17.1 第1ラウンド:SystemV vs. BSD
17.2 第2ラウンド:UI vs. OSF
17.3 Unix Warsの最期

第18章 エピローグ

18.1 4.3BSD Tahoe
18.2 4.3BSD Reno
18.3 4.4BSD

付録A Unix 関連のトピック
[ コメントを読む(0) | コメントする ]

2016年04月17日() [晴れ]

[Security][Neta] Facebookの情報漏洩の結果、悪用可能な状態に

すでにご存じな人もいるでしょうし、オレオレ詐欺などでも十分使用されるネタなのですが、Facebookの検索機能についてご存じでしょうか。

SMS認証を前提としている仕組みが糞食らえだと思うのですが、逆に個人情報収集のよいツールになっているのです。
ちなみに、私はキャリア電話を数年前に捨ててPHSに絞り、二度とつかわねえと以前解約した携帯電話、ハゲの会社に買収され、また戻ってきてしまったという悲い出来事。今となってはSMS認証を前提とするソーシャルが多いことから、私はアカウントすら作る権利がありませんwひゃっはーww なので、LINEとか、使えないのです。かといって、LINEが使いたいからといって、悪質なスパイウェア並のアプリを入れたいとも思わないし、連携でFacebook認証をしたいとも思わないし。 (LINEの場合、アカウントを作ろうとして認証した瞬間、アドレス帳をインポートして、電話番号を登録しているユーザーにアカウントを作ったという通知が行くとか誰かかいてたな。それこそプライバシーの侵害だ)

でだ、SMS認証をすることを前提とし、かつアドレス帳を抜き取り、知り合いかもに表示する仕組みがあるのをご存じだろうか。ここで、でたらめな番号をアドレス帳に入れておくのもよいけど、もっと手っ取り早い方法を紹介する。

それは、電話番号を検索するってこと。
そうすると、SMS認証した番号で検索からした場合、番号の持ち主と名前が誰でもわかるっていう仕組み。
一応、ここは、プライバシーの設定で、「私を検索できる人」の項目を適切に設定すれば、一応防ぐことは可能らしい。
番号を検索することで、知り合いにたどり着けるとい利便性の向上という表向きの顔があるだろうが、
私から見たら、不当に収集した番号を検索することにより、個人情報を表示するサービスといっても過言ではない。

公開範囲を適切に設定してるのは全体からしてわずかだと想定されることから、 適当に入力するとあっさりヒットする。
番号の組み合わせ(実在するパターン)は、後述する総務省の電気通信番号指定状況の割り当て一覧から見ればよい。

試してみるとこのような感じ。

Facebookで公開されたコンテンツや名前などからリストを作成し、オレオレ詐欺や○○さんといって、脅迫電話なども可能になるのではないか。悪質な使い方をするための情報収集手段として、ターゲット(獲物)を探すのには格好のツールとなりそうだ。
ということで、こうやって調べて、 名前と番号のリストを作成すれば、大規模な名簿の作成が可能である。
また、プロフィールから在住してる場所や出身がわかることも多いし、コンテンツから活動エリアもわかるだろう。
そもそも論として、電話番号とネットのアプリケーションを紐付けるのは反対だ。
私はSMSを出来る環境を一切持ってないので、どうでもいいが、それを前提とされた場合、必要に応じてアカウントを作成せざる得ない場合にはあきらめるしかない。
つーか、そういう状況が本当に糞だ。
複数アカウントを持たせたくないというのであれば、他の方法を考えるのが筋だろう。そもそも、SMSなんて、認証に使う意味が果たしてあるのか。
先日、 とあるサービスでアカウントを作成した際、SMS認証を要求され、SMS出来る環境がないので、でたらめの番号を何度も入力してみた。何十回と間違えても問題ないようなので、簡単にSMSスパムが可能だ。深夜に実施すると、嫌がらせも可能だ。

ちなみに、今は、J-Phoneなどはvodafoneを経てソフトバンクになっており全国一律になっているが、以前の情報を持っている場合は、キャリア情報だけではなく、地域なども判別可能となっている。 *1

総務省:電気通信番号指定状況

ということで、こうやって調べて、名前と番号のリストを作成すれば、大規模な名簿の作成が可能である。 また、プロフィールから在住してる場所や出身がわかることも多いし、コンテンツから活動エリアもわかるだろう。
そもそも論として、電話番号とネットのアプリケーションを紐付けるのは反対だ。
私はSMSを出来る環境を一切持ってないので、どうでもいいが、それを前提とされた場合、必要に応じてアカウントを作成せざる得ない場合にはあきらめるしかない。つーか、そういう状況が本当に糞だ。


*1: ナンバーポータビリティーを使うと、事業者間を移転出来るため、必ずしもではないが、初期に契約した地域は特定可能。また、引っ越しした場合も同様であるし、それだけ長いこと番号を使い続けてる人も多いわけではないのであくまでも参考に。
[ コメントを読む(0) | コメントする ]

Diary for 15 day(s)
Powered by hns-2.19.6, HyperNikkiSystem Project




(c) Copyright 1998-2014 tomocha. All rights reserved.